summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-07-08 10:29:02 -0500
committerEric Bavier <bavier@member.fsf.org>2016-07-20 21:16:24 -0500
commitb730b43770249f41dc7987b912cdc17df7035238 (patch)
tree92a3af44f490021c6af0b29e358d6cb545203d3a /gnu/packages/maths.scm
parent64dcc2896389475b0a3133854952bea1fe52cada (diff)
downloadpatches-b730b43770249f41dc7987b912cdc17df7035238.tar
patches-b730b43770249f41dc7987b912cdc17df7035238.tar.gz
gnu: petsc: Make header generation reproducible.
* gnu/packages/maths.scm (petsc)[arguments]: Scrub timestamp from petscmachineinfo.h header.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index b3780fa265..23bdb0d8ef 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -842,11 +842,13 @@ ASCII text files using Gmsh's own scripting language.")
(format #t "configure flags: ~s~%" flags)
(zero? (apply system* "./configure" flags)))))
(add-after 'configure 'clean-local-references
- ;; Try to keep build directory names from leaking into compiled code
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(substitute* (find-files "." "^petsc(conf|machineinfo).h$")
- (((getcwd)) out)))))
+ ;; Prevent build directory from leaking into compiled code
+ (((getcwd)) out)
+ ;; Scrub timestamp for reproducibility
+ ((".*Libraries compiled on.*") "")))))
(add-after 'install 'clean-install
;; Try to keep installed files from leaking build directory names.
(lambda* (#:key inputs outputs #:allow-other-keys)