summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-07-22 15:27:16 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-07-22 18:24:22 +0300
commit430e67a4596343ed215bee649fa13cca7687451f (patch)
tree23ebab265c0601888a54dc192e655150d6a01cee /gnu/packages/maths.scm
parent18d4d10f34e43744ffa79e07894b96bf38f1554f (diff)
downloadpatches-430e67a4596343ed215bee649fa13cca7687451f.tar
patches-430e67a4596343ed215bee649fa13cca7687451f.tar.gz
gnu: gnuplot: Update to upstream's re-release of 5.0.4.
* gnu/packages/maths.scm (gnuplot): Add a guix revision number to the version scheme of gnuplot to force an update.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm55
1 files changed, 30 insertions, 25 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ef84986057..ad7d0e22ee 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -380,35 +380,40 @@ singular value problems.")
"See LICENSE in the distribution."))))
(define-public gnuplot
- (package
- (name "gnuplot")
- (version "5.0.4")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/gnuplot/gnuplot/"
- version "/gnuplot-" version ".tar.gz"))
- (sha256
- (base32
- "08vpmhl85l48xcccx8jrkamalih2d6z9ppqpsppwii9y2l1p3297"))))
- (build-system gnu-build-system)
- (inputs `(("readline" ,readline)
- ("cairo" ,cairo)
- ("pango" ,pango)
- ("gd" ,gd)))
- (native-inputs `(("pkg-config" ,pkg-config)
- ("texlive" ,texlive-minimal)))
- (home-page "http://www.gnuplot.info")
- (synopsis "Command-line driven graphing utility")
- (description "Gnuplot is a portable command-line driven graphing
+ ;; Gnuplot version 5.0.4 was updated in-place, resulting in a hash mismatch.
+ ;; This can be removed at the next version update.
+ (let ((upstream-version "5.0.4")
+ (guix-revision "1"))
+ (package
+ (name "gnuplot")
+ (version (string-append upstream-version "-" guix-revision))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/gnuplot/gnuplot/"
+ upstream-version "/gnuplot-"
+ upstream-version ".tar.gz"))
+ (sha256
+ (base32
+ "07n3w12dkcxjnhsvsliaqnkhajhi818v6q8mkpmpbplbf92vh70m"))))
+ (build-system gnu-build-system)
+ (inputs `(("readline" ,readline)
+ ("cairo" ,cairo)
+ ("pango" ,pango)
+ ("gd" ,gd)))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("texlive" ,texlive-minimal)))
+ (home-page "http://www.gnuplot.info")
+ (synopsis "Command-line driven graphing utility")
+ (description "Gnuplot is a portable command-line driven graphing
utility. It was originally created to allow scientists and students to
visualize mathematical functions and data interactively, but has grown to
support many non-interactive uses such as web scripting. It is also used as a
plotting engine by third-party applications like Octave.")
- ;; X11 Style with the additional restriction that derived works may only be
- ;; distributed as patches to the original.
- (license (license:fsf-free
- "http://gnuplot.cvs.sourceforge.net/gnuplot/gnuplot/Copyright"))))
+ ;; X11 Style with the additional restriction that derived works may only be
+ ;; distributed as patches to the original.
+ (license (license:fsf-free
+ "http://gnuplot.cvs.sourceforge.net/gnuplot/gnuplot/Copyright")))))
(define-public hdf5
(package