summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-09-03 13:15:30 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-09-03 13:24:34 +0200
commitbd3d71cb16de546b534be7a3d03880922f6a1c07 (patch)
tree9356e64e7819198b1d78fd0e97acd323955b4f44 /gnu/packages/maths.scm
parent0481289cbccba2646bf654f0ae49ac9c45602d5d (diff)
downloadpatches-bd3d71cb16de546b534be7a3d03880922f6a1c07.tar
patches-bd3d71cb16de546b534be7a3d03880922f6a1c07.tar.gz
gnu: hdf4: Build with libtirpc.
* gnu/packages/patches/hdf4-tirpc.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/maths.scm (hdf4)[source](patches): Use it. [inputs]: Add LIBTIRPC. [arguments]: Adjust #:configure-flags accordingly.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 38bb81242f..9e515fd3d1 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -100,6 +100,7 @@
#:use-module (gnu packages mpi)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages netpbm)
+ #:use-module (gnu packages onc-rpc)
#:use-module (gnu packages pcre)
#:use-module (gnu packages popt)
#:use-module (gnu packages perl)
@@ -684,7 +685,8 @@ computations.")
(base32 "1wz0586zh91pqb95wvr0pbh71a8rz358fdj6n2ksp85x2cis9lsm"))
(patches (search-patches "hdf4-architectures.patch"
"hdf4-reproducibility.patch"
- "hdf4-shared-fortran.patch"))))
+ "hdf4-shared-fortran.patch"
+ "hdf4-tirpc.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("gfortran" ,gfortran)
@@ -692,10 +694,14 @@ computations.")
("flex" ,flex)))
(inputs
`(("zlib" ,zlib)
- ("libjpeg" ,libjpeg)))
+ ("libjpeg" ,libjpeg)
+ ("libtirpc" ,libtirpc)))
(arguments
`(#:parallel-tests? #f
- #:configure-flags '("--enable-shared")
+ #:configure-flags (list "--enable-shared"
+ (string-append "CPPFLAGS=-I"
+ (assoc-ref %build-inputs "libtirpc")
+ "/include/tirpc"))
#:phases
(modify-phases %standard-phases
;; This is inspired by two of Debian's patches.