summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2019-01-25 11:05:14 -0600
committerEric Bavier <bavier@member.fsf.org>2019-01-25 13:10:05 -0600
commit7e309e8a8d7882516b1d7f4815daf52f296bd46f (patch)
tree8cd25b2ba9485baf25a6924b3556b88c8c1245d0 /gnu/packages/maths.scm
parent6161141e9181ca82f151779f8048b28e093a025f (diff)
downloadpatches-7e309e8a8d7882516b1d7f4815daf52f296bd46f.tar
patches-7e309e8a8d7882516b1d7f4815daf52f296bd46f.tar.gz
gnu: dealii-openmpi: Setup MPI for tests.
* gnu/packages/maths.scm (dealii-openmpi)[arguments]: Add 'mpi-setup' phase.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index e2f3d84d09..66d60639ab 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3494,7 +3494,11 @@ in finite element programs.")
``("-DMPI_C_COMPILER=mpicc"
"-DMPI_CXX_COMPILER=mpicxx"
"-DMPI_Fortran_COMPILER=mpifort"
- ,@,cf))))
+ ,@,cf))
+ ((#:phases phases '%standard-phases)
+ `(modify-phases ,phases
+ (add-before 'check 'mpi-setup
+ ,%openmpi-setup)))))
(synopsis "Finite element library (with MPI support)")))
(define-public flann