summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-06-04 09:27:45 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-06-04 09:30:38 -0400
commitccc963d5286c73dedd2e3a2029e11674b6f14095 (patch)
treeca94521bc304e980ea494b524317598a93dac20c /gnu/packages/maths.scm
parentf83e10e42780ce45c67d67057881fa88dd1d7e16 (diff)
downloadpatches-ccc963d5286c73dedd2e3a2029e11674b6f14095.tar
patches-ccc963d5286c73dedd2e3a2029e11674b6f14095.tar.gz
gnu: maxima: Update to 5.43.0.
* gnu/packages/maths.scm (maxima): Update to 5.43.0. [arguments]: Adjust "patch-paths" and "post-install" phases.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4741a0d5ec..e74898b582 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2760,7 +2760,7 @@ to BMP, JPEG or PNG image formats.")
(define-public maxima
(package
(name "maxima")
- (version "5.42.2")
+ (version "5.43.0")
(source
(origin
(method url-fetch)
@@ -2768,7 +2768,7 @@ to BMP, JPEG or PNG image formats.")
version "-source/" name "-" version ".tar.gz"))
(sha256
(base32
- "0kdncy6137sg3rradirxzj10mkcvafxd892zlclwhr9sa7b12zhn"))
+ "0xyahp4c6509haxh4n1swiqm3421gplkdisa0zypclh3252sbzfw"))
(patches (search-patches "maxima-defsystem-mkdir.patch"))))
(build-system gnu-build-system)
(inputs
@@ -2802,11 +2802,18 @@ to BMP, JPEG or PNG image formats.")
(let* ((sed (string-append (assoc-ref inputs "sed") "/bin/sed"))
(coreutils (assoc-ref inputs "coreutils"))
(dirname (string-append coreutils "/bin/dirname"))
- (head (string-append coreutils "/bin/head")))
+ (head (string-append coreutils "/bin/head"))
+ (perl (string-append (assoc-ref inputs "perl") "/bin/perl"))
+ (python (string-append (assoc-ref inputs "python")
+ "/bin/python3")))
(substitute* "src/maxima.in"
(("sed ") (string-append sed " "))
(("dirname") dirname)
(("head") head))
+ (substitute* "doc/info/Makefile.in"
+ (("/usr/bin/env perl") perl))
+ (substitute* "doc/info/build_html.sh.in"
+ (("python") python))
#t)))
(add-before 'check 'pre-check
(lambda _
@@ -2838,9 +2845,6 @@ to BMP, JPEG or PNG image formats.")
(mkdir-p "share/emacs")
(mkdir-p "share/doc")
(symlink
- (string-append datadir "/emacs/")
- (string-append out "/share/emacs/site-lisp"))
- (symlink
(string-append datadir "/doc/")
(string-append out "/share/doc/maxima"))
(with-atomic-file-replacement