summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2019-05-30 23:27:46 -0500
committerEric Bavier <bavier@member.fsf.org>2019-05-31 19:41:41 -0500
commite586c6faf3838daeadfe9aa97ae4d428f0613d67 (patch)
tree9c90be06fc99a055a86ca4609bbcd29e8483cfbb /gnu/packages/maths.scm
parent5c48519204cf76b3770fd217680f93497612240a (diff)
downloadpatches-e586c6faf3838daeadfe9aa97ae4d428f0613d67.tar
patches-e586c6faf3838daeadfe9aa97ae4d428f0613d67.tar.gz
gnu: petsc-complex-mpi: Setup MPI for tests.
* gnu/packages/maths.scm (petsc-complex-mpi)[arguments]: Add 'mpi-setup phase.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f88f48b82b..cd6f5780d5 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1845,7 +1845,11 @@ scientific applications modeled by partial differential equations.")
``("--with-mpiexec=mpirun"
,(string-append "--with-mpi-dir="
(assoc-ref %build-inputs "openmpi"))
- ,@(delete "--with-mpi=0" ,cf)))))
+ ,@(delete "--with-mpi=0" ,cf)))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-before 'configure 'mpi-setup
+ ,%openmpi-setup)))))
(synopsis "Library to solve PDEs (with complex scalars and MPI support)")))
(define-public python-petsc4py