summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 14:45:34 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-12 15:29:43 +0100
commit4dba441c2a7f79d1fdb7b766ce039690701b2c5c (patch)
treea9144f53063447cd30dfc54aa3ab66361182bbc2 /gnu/packages/maths.scm
parentecae16bec5a1ff28e9aa648760d5f75342acf5f9 (diff)
downloadpatches-4dba441c2a7f79d1fdb7b766ce039690701b2c5c.tar
patches-4dba441c2a7f79d1fdb7b766ce039690701b2c5c.tar.gz
gnu: hdf5: Build with -fPIC.
* gnu/packages/maths.scm (hdf5)[arguments]: Add -fPIC to CFLAGS and CXXFLAGS.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 3830393706..d564de4245 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2014, 2015, 2016, 2017, 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2014 Mathieu Lirzin <mathieu.lirzin@openmailbox.org>
-;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
@@ -704,7 +704,9 @@ incompatible with HDF5.")
#:configure-flags '("--enable-cxx"
"--enable-fortran"
"--enable-fortran2003")
-
+ ;; Use -fPIC to allow the R bindings to link with the static libraries
+ #:make-flags (list "CFLAGS=-fPIC"
+ "CXXFLAGS=-fPIC")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-configure