summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2018-09-26 12:59:54 +0100
committerLeo Famulari <leo@famulari.name>2018-10-04 18:21:17 -0400
commit9e2aa70bad8c06cdf9a44065a31f12b3205e92e0 (patch)
treee058ced6209fcb0b1ef6e6fb60aa2e47d9515a71 /gnu/packages/maths.scm
parentd8b042326dda505c8e65789572e3dd65311ba8e3 (diff)
downloadpatches-9e2aa70bad8c06cdf9a44065a31f12b3205e92e0.tar
patches-9e2aa70bad8c06cdf9a44065a31f12b3205e92e0.tar.gz
gnu: petsc-openmpi: Configure with support for MUMPS solver.
* gnu/packages/maths.scm (petsc-openmpi)[inputs]: Add metis, mumps-openmpi, scalapack and pt-scotch. [arguments]: Add "--with-PACKAGENAME=1" flags. Move 'mpi-setup' phase ahead of 'configure' phase. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index b7d669ccea..766c6e920f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1702,13 +1702,21 @@ scientific applications modeled by partial differential equations.")
(package (inherit petsc)
(name "petsc-openmpi")
(inputs
- `(("openmpi" ,openmpi)
- ("hdf5" ,hdf5-parallel-openmpi)
+ `(("hdf5" ,hdf5-parallel-openmpi)
+ ("metis" ,metis)
+ ("mumps" ,mumps-openmpi)
+ ("openmpi" ,openmpi)
+ ("scalapack" ,scalapack)
+ ("scotch" ,pt-scotch)
,@(package-inputs petsc)))
(arguments
(substitute-keyword-arguments (package-arguments petsc)
((#:configure-flags cf)
``("--with-mpiexec=mpirun"
+ "--with-metis=1"
+ "--with-mumps=1"
+ "--with-scalapack=1"
+ "--with-ptscotch=1"
,(string-append "--with-mpi-dir="
(assoc-ref %build-inputs "openmpi"))
,(string-append "--with-hdf5-include="
@@ -1718,9 +1726,9 @@ scientific applications modeled by partial differential equations.")
,@(delete "--with-mpi=0" ,cf)))
((#:phases phases)
`(modify-phases ,phases
- (add-before 'check 'mpi-setup
+ (add-before 'configure 'mpi-setup
,%openmpi-setup)))))
- (synopsis "Library to solve PDEs (with MPI support)")))
+ (synopsis "Library to solve PDEs (with MUMPS and MPI support)")))
(define-public petsc-complex-openmpi
(package (inherit petsc-complex)
@@ -1737,7 +1745,6 @@ scientific applications modeled by partial differential equations.")
,@(delete "--with-mpi=0" ,cf)))))
(synopsis "Library to solve PDEs (with complex scalars and MPI support)")))
-
(define-public python-kiwisolver
(package
(name "python-kiwisolver")