summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-21 05:15:55 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-21 15:02:48 +0100
commit6c96b5452cd72309d12f2d1a3bb4528a365635f6 (patch)
tree792206086e9e5467febe4caf8fd2aae2fbbabfa7 /gnu/packages/maths.scm
parentbe5dc5fb18a4b72977748c5f077062be4e8accbc (diff)
downloadpatches-6c96b5452cd72309d12f2d1a3bb4528a365635f6.tar
patches-6c96b5452cd72309d12f2d1a3bb4528a365635f6.tar.gz
gnu: lpsolve: Update phase style.
* gnu/packages/maths.scm (lpsolve)[arguments]: Use INVOKE and INSTALL-FILE, and end phases with #t.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0f87346ea9..bc71473237 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3073,16 +3073,17 @@ specifications.")
(("isnan\\(0\\)") "isnan(0.)")))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no check target
+ `(#:tests? #f ; no check target
#:phases
(modify-phases %standard-phases
- (delete 'configure)
+ (delete 'configure) ; no configure script
(replace 'build
(lambda _
- (and (with-directory-excursion "lpsolve55"
- (zero? (system* "bash" "ccc")))
- (with-directory-excursion "lp_solve"
- (zero? (system* "bash" "ccc"))))))
+ (with-directory-excursion "lpsolve55"
+ (invoke "bash" "ccc"))
+ (with-directory-excursion "lp_solve"
+ (invoke "bash" "ccc"))
+ #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -3091,11 +3092,8 @@ specifications.")
;; This is where LibreOffice expects to find the header
;; files, and where they are installed by Debian.
(include (string-append out "/include/lpsolve")))
- (mkdir-p lib)
- (copy-file "lpsolve55/bin/ux64/liblpsolve55.a"
- (string-append lib "/liblpsolve55.a"))
- (copy-file "lpsolve55/bin/ux64/liblpsolve55.so"
- (string-append lib "/liblpsolve55.so"))
+ (install-file "lpsolve55/bin/ux64/liblpsolve55.a" lib)
+ (install-file "lpsolve55/bin/ux64/liblpsolve55.so" lib)
(install-file "lp_solve/bin/ux64/lp_solve" bin)
;; Install a subset of the header files as on Debian