summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-05-13 10:32:47 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-05-17 20:23:17 +0300
commitf0a9cb9cf03b2b511342c768811a6a353b6e438a (patch)
tree47bf57435c7dd85fe95bea99b9c8d0152c0fe937 /gnu/packages/maths.scm
parentd74ea9e560d6419e6170991520c640483d21840b (diff)
downloadpatches-f0a9cb9cf03b2b511342c768811a6a353b6e438a.tar
patches-f0a9cb9cf03b2b511342c768811a6a353b6e438a.tar.gz
gnu: gsl: Disable failing tests on powerpc.
* gnu/packages/maths.scm (gsl)[arguments]: Skip the same set of tests on powerpc as skipped on aarch64.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1821b2b1c7..e62fb38086 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015, 2018 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Fabian Harfert <fhmgufs@web.de>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2018, 2020 Kei Kebreau <kkebreau@posteo.net>
@@ -472,8 +472,9 @@ precision floating point numbers.")
(arguments
(let ((system (%current-system)))
(cond
- ((string-prefix? "aarch64" system)
- ;; Some sparse matrix tests are failing on AArch64:
+ ((or (string-prefix? "aarch64" system)
+ (string-prefix? "powerpc" system))
+ ;; Some sparse matrix tests are failing on AArch64 and PowerPC:
;; https://lists.gnu.org/archive/html/bug-gsl/2020-04/msg00001.html
'(#:phases (modify-phases %standard-phases
(add-before 'check 'disable-failing-tests