summaryrefslogtreecommitdiff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorFabian Harfert <fhmgufs@web.de>2016-02-10 00:00:24 +0100
committerEfraim Flashner <efraim@flashner.co.il>2016-02-17 13:39:41 +0200
commit7af1ca29f45e66c92e7f560af2eacce77a008298 (patch)
tree047914ee8a7295b81df0f4b0d5a922346ccc1697 /gnu/packages/mate.scm
parentf2c7369abca76b98be15eb56f02114879235d8e6 (diff)
downloadpatches-7af1ca29f45e66c92e7f560af2eacce77a008298.tar
patches-7af1ca29f45e66c92e7f560af2eacce77a008298.tar.gz
gnu: Add mate-menus.
* gnu/packages/mate.scm (mate-menus): New variable.
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm44
1 files changed, 43 insertions, 1 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 7bfdaefd8f..c4b75f8609 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -30,7 +30,8 @@
#:use-module (gnu packages xorg)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages base)
- #:use-module (gnu packages xml))
+ #:use-module (gnu packages xml)
+ #:use-module (gnu packages python))
(define-public mate-icon-theme
(package
@@ -167,3 +168,44 @@ desktop and the mate-about program.")
"This library provides acess to weather information from the internet for
the MATE desktop environment.")
(license license:lgpl2.1+)))
+
+(define-public mate-menus
+ (package
+ (name "mate-menus")
+ (version "1.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://pub.mate-desktop.org/releases/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1i4m3fj0vd85zyhqhm8x9yr0h5i08aa4l99zqvbk59ncj6z3bdxh"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after
+ 'unpack 'fix-introspection-install-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* '("configure")
+ (("`\\$PKG_CONFIG --variable=girdir gobject-introspection-1.0`")
+ (string-append "\"" out "/share/gir-1.0/\""))
+ (("\\$\\(\\$PKG_CONFIG --variable=typelibdir gobject-introspection-1.0\\)")
+ (string-append out "/lib/girepository-1.0/")))))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)
+ ("gobject-introspection" ,gobject-introspection)))
+ (inputs
+ `(("python" ,python-2)))
+ (propagated-inputs
+ `(("glib" ,glib)))
+ (home-page "http://mate-desktop.org/")
+ (synopsis "Freedesktop menu specification implementation for MATE")
+ (description
+ "The package contains an implementation of the freedesktop menu
+specification, the MATE menu layout configuration files, .directory files and
+assorted menu related utility programs.")
+ (license (list license:gpl2+ license:lgpl2.0+))))