summaryrefslogtreecommitdiff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-08-06 17:22:41 +0000
committerEfraim Flashner <efraim@flashner.co.il>2017-09-12 09:55:10 +0300
commit42a6eaacebe4d4611f4c9e0f53772434e5d939e6 (patch)
tree42789115d4a4e6f4c523574dcc10329ca3fcc178 /gnu/packages/mate.scm
parentfa7647c6317c5d8a6e3a41b72c3f9e36828531da (diff)
downloadpatches-42a6eaacebe4d4611f4c9e0f53772434e5d939e6.tar
patches-42a6eaacebe4d4611f4c9e0f53772434e5d939e6.tar.gz
gnu: Add caja.
* gnu/packages/mate.scm (caja): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index c64e26124d..5962108655 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -24,8 +24,10 @@
#:use-module (guix download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (gnu packages)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
#:use-module (gnu packages gnome)
@@ -33,6 +35,7 @@
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages base)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages photo)
#:use-module (gnu packages python))
(define-public mate-icon-theme
@@ -205,3 +208,58 @@ the MATE desktop environment.")
specification, the MATE menu layout configuration files, .directory files and
assorted menu related utility programs.")
(license (list license:gpl2+ license:lgpl2.0+))))
+
+(define-public caja
+ (package
+ (name "caja")
+ (version "1.18.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pub.mate-desktop.org/releases/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0mljqcx7k8p27854zm7qzzn8ca6hs7hva9p43hp4p507z52caqmm"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:configure-flags '("--disable-update-mimedb")
+ #:tests? #f ; tests fail even with display set
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests require a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ ;; For the missing /etc/machine-id.
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ #t)))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)
+ ("glib:bin" ,glib "bin")
+ ("xorg-server" ,xorg-server)
+ ("gobject-introspection" ,gobject-introspection)))
+ (inputs
+ `(("exempi" ,exempi)
+ ("gtk+" ,gtk+)
+ ("gvfs" ,gvfs)
+ ("libexif" ,libexif)
+ ("libnotify" ,libnotify)
+ ("libsm" ,libsm)
+ ("libxml2" ,libxml2)
+ ("mate-desktop" ,mate-desktop)
+ ("startup-notification" ,startup-notification)))
+ (home-page "https://mate-desktop.org/")
+ (synopsis "File manager for the MATE desktop")
+ (description
+ "Caja is the official file manager for the MATE desktop.
+It allows for browsing directories, as well as previewing files and launching
+applications associated with them. Caja is also responsible for handling the
+icons on the MATE desktop. It works on local and remote filesystems.")
+ ;; There is a note about a TRADEMARKS_NOTICE file in COPYING which
+ ;; does not exist. It is safe to assume that this is of no concern
+ ;; for us.
+ (license license:gpl2+)))