summaryrefslogtreecommitdiff
path: root/gnu/packages/mastodon.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-06-25 19:09:51 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-06-25 19:09:51 +0300
commit8566d8793b005ae8ee2bf63b8817b301c94849cb (patch)
tree43da678cf6298ec6cd2a12a422c39d182e8acb19 /gnu/packages/mastodon.scm
parent31263ec227c077f55893de61e8b839d7c97ae0c1 (diff)
downloadpatches-8566d8793b005ae8ee2bf63b8817b301c94849cb.tar
patches-8566d8793b005ae8ee2bf63b8817b301c94849cb.tar.gz
gnu: toot: Don't install the Makefile.
* gnu/packages/mastodon.scm (toot)[arguments]: Add custom phase to prevent installing data_files.
Diffstat (limited to 'gnu/packages/mastodon.scm')
-rw-r--r--gnu/packages/mastodon.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/mastodon.scm b/gnu/packages/mastodon.scm
index 028745f681..cd12f5a7fd 100644
--- a/gnu/packages/mastodon.scm
+++ b/gnu/packages/mastodon.scm
@@ -42,6 +42,12 @@
'(#:phases
(modify-phases %standard-phases
(delete 'check)
+ ;; see https://github.com/ihabunek/toot/issues/91
+ (add-after 'unpack 'dont-install-Makefile
+ (lambda _
+ (substitute* "setup.py"
+ (("data_files.*" all) ""))
+ #t))
(add-after 'install 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
(add-installed-pythonpath inputs outputs)