summaryrefslogtreecommitdiff
path: root/gnu/packages/mastodon.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-29 23:23:59 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-29 23:23:59 +0200
commit6e1f8d552b73e508bba47dedb5676ce5ccdcc398 (patch)
tree952a8fa2652ad26946100707311824b8c7a88768 /gnu/packages/mastodon.scm
parentc24b896365ebf0c783140e53e000305e682d18c5 (diff)
parent8e92d5465fc154fed5d06f7e4a64d7dcccded74d (diff)
downloadpatches-6e1f8d552b73e508bba47dedb5676ce5ccdcc398.tar
patches-6e1f8d552b73e508bba47dedb5676ce5ccdcc398.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/mastodon.scm')
-rw-r--r--gnu/packages/mastodon.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/mastodon.scm b/gnu/packages/mastodon.scm
index 028745f681..cd12f5a7fd 100644
--- a/gnu/packages/mastodon.scm
+++ b/gnu/packages/mastodon.scm
@@ -42,6 +42,12 @@
'(#:phases
(modify-phases %standard-phases
(delete 'check)
+ ;; see https://github.com/ihabunek/toot/issues/91
+ (add-after 'unpack 'dont-install-Makefile
+ (lambda _
+ (substitute* "setup.py"
+ (("data_files.*" all) ""))
+ #t))
(add-after 'install 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
(add-installed-pythonpath inputs outputs)