aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/marst.scm
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-05-02 17:53:40 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-05-02 17:53:40 +0200
commitc3052d6bcd2193b258fb92b99291a4918931fe36 (patch)
tree0e0cbbc019e68f4f1c865b4d2f5e341eb45d96ee /gnu/packages/marst.scm
parent0bfb9b439953b755a510974e51e651f79526a5a4 (diff)
parentb74f64a960542b0679ab13de0dd28adc496cf084 (diff)
downloadpatches-c3052d6bcd2193b258fb92b99291a4918931fe36.tar
patches-c3052d6bcd2193b258fb92b99291a4918931fe36.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/marst.scm')
-rw-r--r--gnu/packages/marst.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/marst.scm b/gnu/packages/marst.scm
new file mode 100644
index 0000000000..7d4a4f364d
--- /dev/null
+++ b/gnu/packages/marst.scm
@@ -0,0 +1,43 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright 2016 John Darrington <jmd@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages marst)
+ #:use-module (guix packages)
+ #:use-module (guix licenses)
+ #:use-module (guix download)
+ #:use-module (gnu packages compression)
+ #:use-module (guix build-system gnu))
+
+(define-public marst
+ (package
+ (name "marst")
+ (version "2.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://gnu/" name "/" name "-" version
+ ".tar.gz"))
+ (sha256
+ (base32 "0l6swjy8fjrqw89ghc1vvakg21jmpfkpsw92yssrzkg3rg8vkrry"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.gnu.org/software/marst")
+ (synopsis "Algol to C translator")
+ (description "MARST is an Algol-to-C translator. It automatically translates programs
+written on the algorithmic language Algol 60 to the C programming language.")
+ (license gpl3+)))