summaryrefslogtreecommitdiff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-12-20 08:53:05 +0100
committerRutger Helling <rhelling@mykolab.com>2018-12-20 08:59:36 +0100
commite2dd54c09035aadce8a363c3b1faf703f025d62d (patch)
tree91166273c1eb23ce82d82f7873be903cd35a3091 /gnu/packages/man.scm
parent36e1ab842d5e0c221d15385bc7c535ee81b03ff8 (diff)
downloadpatches-e2dd54c09035aadce8a363c3b1faf703f025d62d.tar
patches-e2dd54c09035aadce8a363c3b1faf703f025d62d.tar.gz
gnu: Add scdoc.
* gnu/packages/man.scm (scdoc): New variable.
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index b640884933..8989dd230b 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -228,6 +229,37 @@ automatically.")
(base32
"1p5830h88cx0zn0snwaj0vpph81xicpsirfwlxmcgjrlmn0nm3sj"))))))
+(define-public scdoc
+ (package
+ (name "scdoc")
+ (version "1.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://git.sr.ht/%7Esircmpwn/scdoc/archive/" version
+ ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1ca3js4arkg28gg2iszxxyrq7kgsrz482d1szv5dfd471h3vr5m3"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags '("CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'install 'hardcode-paths
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("/usr/local") (assoc-ref outputs "out")))
+ #t)))))
+ (home-page "https://git.sr.ht/~sircmpwn/scdoc")
+ (synopsis "Simple man page generator")
+ (description "scdoc is a simple man page generator written for POSIX systems
+in C99.")
+ ;; MIT license, see /share/doc/scdoc-1.6.0/COPYING.
+ (license expat)))
+
(define-public txt2man
(package
(name "txt2man")