summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorCarlos Sánchez de La Lama <csanchezdll@gmail.com>2017-01-04 23:47:24 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-04 23:55:36 +0100
commitfc649d0aada3d71de75ee6ca149bc8bbd045efd5 (patch)
treee006ea05f2bd8ce37e45225cdadbfd0467807e48 /gnu/packages/make-bootstrap.scm
parent0c1b29db3ae1909abb3f074a2276f70cee4ab014 (diff)
downloadpatches-fc649d0aada3d71de75ee6ca149bc8bbd045efd5.tar
patches-fc649d0aada3d71de75ee6ca149bc8bbd045efd5.tar.gz
gnu: gcc: Adjust for PowerPC.
* gnu/packages/gcc.scm (gcc-4.7)[arguments]: Add powerpc specific substitutions for dynamic linker and start files locations in 'pre-configure' phase. * gnu/packages/make-bootstrap.scm (%gcc-static)[arguments]: Add "gcc/config/rs6000/sysv4.h" to the list of files in 'remove-lgcc_s' phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index f31db6aaef..fcd22ee68b 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -441,8 +441,9 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
;; the 'pre-configure phase of our main gcc package, because
;; that shared library is not present in this static gcc. See
;; <https://lists.gnu.org/archive/html/guix-devel/2015-01/msg00008.html>.
- (substitute* (find-files "gcc/config"
- "^gnu-user.*\\.h$")
+ (substitute* (cons "gcc/config/rs6000/sysv4.h"
+ (find-files "gcc/config"
+ "^gnu-user.*\\.h$"))
((" -lgcc_s}}") "}}")))
,phases)))))
(native-inputs