summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-06-26 17:06:30 +0200
committerLudovic Courtès <ludo@gnu.org>2015-06-26 17:06:30 +0200
commitc92f1c0a3315557f072702aa64615cd4ff73fe36 (patch)
treed7fa87b3c5d29d43e898506832b1eebda4fc2e66 /gnu/packages/make-bootstrap.scm
parent744985761a3fbfe8543379373d1d54d774ab2b34 (diff)
downloadpatches-c92f1c0a3315557f072702aa64615cd4ff73fe36.tar
patches-c92f1c0a3315557f072702aa64615cd4ff73fe36.tar.gz
gnu: Refer to 'gcc' instead of 'gcc-4.9'.
* gnu/packages/commencement.scm (gcc-boot0, cross-gcc-wrapper, libstdc++, gcc-final): Refer to GCC instead of GCC-4.9. * gnu/packages/cross-base.scm (%xgcc): New variable. (cross-gcc-arguments, cross-gcc): Refer to %XGCC instead of GCC-4.9. * gnu/packages/llvm.scm (clang-from-llvm): Refer to GCC instead of GCC-4.9. * gnu/packages/make-bootstrap.scm (package-with-relocatable-glibc, %gcc-static, %gcc-stripped): Likewise.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 2a7c4bd6f2..e140582a4a 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -103,11 +103,11 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
("cross-binutils" ,(cross-binutils target))
,@%final-inputs))
`(("libc" ,(glibc-for-bootstrap))
- ("gcc" ,(package (inherit gcc-4.9)
+ ("gcc" ,(package (inherit gcc)
(outputs '("out")) ; all in one so libgcc_s is easily found
(inputs
`(("libc",(glibc-for-bootstrap))
- ,@(package-inputs gcc-4.9)))))
+ ,@(package-inputs gcc)))))
,@(fold alist-delete %final-inputs '("libc" "gcc")))))
(package-with-explicit-inputs p inputs
@@ -389,7 +389,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(define %gcc-static
;; A statically-linked GCC, with stripped-down functionality.
(package-with-relocatable-glibc
- (package (inherit gcc-4.9)
+ (package (inherit gcc)
(name "gcc-static")
(outputs '("out")) ; all in one
(arguments
@@ -398,7 +398,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(srfi srfi-1)
(srfi srfi-26)
(ice-9 regex))
- ,@(substitute-keyword-arguments (package-arguments gcc-4.9)
+ ,@(substitute-keyword-arguments (package-arguments gcc)
((#:guile _) #f)
((#:implicit-inputs? _) #t)
((#:configure-flags flags)
@@ -453,12 +453,12 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
("gmp-native" ,gmp)
("mpfr-native" ,mpfr)
("mpc-native" ,mpc)
- ,@(package-native-inputs gcc-4.9))
- (package-native-inputs gcc-4.9))))))
+ ,@(package-native-inputs gcc))
+ (package-native-inputs gcc))))))
(define %gcc-stripped
;; The subset of GCC files needed for bootstrap.
- (package (inherit gcc-4.9)
+ (package (inherit gcc)
(name "gcc-stripped")
(build-system trivial-build-system)
(source #f)