summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-11-20 19:01:27 +0100
committerLudovic Courtès <ludo@gnu.org>2013-11-20 19:01:27 +0100
commit953ab5030f1ee870944a291f9e8edc491b198969 (patch)
tree6050743caf3dae9617cf2db636e0e679788ceecb /gnu/packages/make-bootstrap.scm
parentf39298004162b94447a301d582e3f73892c99953 (diff)
downloadpatches-953ab5030f1ee870944a291f9e8edc491b198969.tar
patches-953ab5030f1ee870944a291f9e8edc491b198969.tar.gz
gnu: make-bootstrap: Simplify '%gcc-static'.
* gnu/packages/make-bootstrap.scm (%gcc-static): Add a bunch of --disable configure flags. Remove useless 'inputs' field.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index defc32bc08..7f7a808542 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -406,6 +406,9 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
"--disable-plugin"
"--enable-languages=c"
"--disable-libmudflap"
+ "--disable-libatomic"
+ "--disable-libsanitizer"
+ "--disable-libitm"
"--disable-libgomp"
"--disable-libssp"
"--disable-libquadmath"
@@ -415,12 +418,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
((#:make-flags flags)
(if (%current-target-system)
`(cons "LDFLAGS=-static" ,flags)
- `(cons "BOOT_LDFLAGS=-static" ,flags))))))
- (inputs `(("gmp-source" ,(package-source gmp))
- ("mpfr-source" ,(package-source mpfr))
- ("mpc-source" ,(package-source mpc))
- ("binutils" ,binutils)
- ,@(package-inputs gcc-4.8))))))
+ `(cons "BOOT_LDFLAGS=-static" ,flags)))))))))
(define %gcc-stripped
;; The subset of GCC files needed for bootstrap.