summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-06-14 20:52:09 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-06-23 08:09:39 -0400
commit1bd3f8498632416fd87be737769a20bfc37f5602 (patch)
tree1e91698af5eee79d341e2a7efe947d616bbf522e /gnu/packages/mail.scm
parentf4eae897cb31a1f3d6d10a42ef67710bf395057d (diff)
downloadpatches-1bd3f8498632416fd87be737769a20bfc37f5602.tar
patches-1bd3f8498632416fd87be737769a20bfc37f5602.tar.gz
gnu: Add notmuch.
* gnu/packages/mail.scm (notmuch): New variable.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 796dcd7e88..d9c847d4ce 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -44,6 +44,8 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages flex)
#:use-module (gnu packages bdb)
+ #:use-module (gnu packages gdb)
+ #:use-module (gnu packages samba)
#:use-module ((guix licenses)
#:select (gpl2 gpl2+ gpl3+ lgpl2.1+ lgpl3+))
#:use-module (guix packages)
@@ -326,4 +328,42 @@ messages you need; in addition, it allows you to view messages, extract
attachments, create new maildirs, and so on.")
(license gpl3+)))
+(define-public notmuch
+ (package
+ (name "notmuch")
+ (version "0.18")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://notmuchmail.org/releases/notmuch-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1ia65iazz2hlp3ja57yn0chs27rzsky9kayw74njwmgi9faw3vh9"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ;; FIXME: Test suite hangs and times out.
+ #:phases (alist-replace
+ 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (setenv "CONFIG_SHELL" (which "sh"))
+ (let ((out (assoc-ref outputs "out")))
+ (zero? (system* "./configure"
+ (string-append "--prefix=" out)))))
+ %standard-phases)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("emacs" ,emacs)
+ ("glib" ,glib)
+ ("gmime" ,gmime)
+ ("talloc" ,talloc)
+ ("xapian" ,xapian)
+ ("zlib" ,zlib)))
+ (home-page "http://notmuchmail.org/")
+ (synopsis "Thread-based email index, search, and tagging")
+ (description
+ "Notmuch is a command-line based program for indexing, searching, read-
+ing, and tagging large collections of email messages.")
+ (license gpl3+)))
+
;;; mail.scm ends here