summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-12-04 05:48:30 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-12-04 23:10:21 +0100
commit29a87ed18c57cd4c084f73a349e9ac54f0e621c7 (patch)
tree60aaf20c0453ccd475fcd0a096798e7cd2ee60e9 /gnu/packages/mail.scm
parent8f15c1c9fe71bf2f1f5304481223d06f59103347 (diff)
downloadpatches-29a87ed18c57cd4c084f73a349e9ac54f0e621c7.tar
patches-29a87ed18c57cd4c084f73a349e9ac54f0e621c7.tar.gz
gnu: imapfilter: Update to 2.6.16.
* gnu/packages/mail.scm (imapfilter): Update to 2.6.16. [arguments]: Remove ‘fix-include-path’ phase.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 7b9470606a..555fe70de4 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2851,7 +2851,7 @@ PGP handling, multiple servers, and secure connections.")
(define-public imapfilter
(package
(name "imapfilter")
- (version "2.6.12")
+ (version "2.6.16")
(source
(origin
(method git-fetch)
@@ -2860,7 +2860,7 @@ PGP handling, multiple servers, and secure connections.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0vzpc54fjf5vb5vx5w0fl20xvx1k9cg6a3hbl86mm8kwsqf3wrab"))))
+ (base32 "0f65sg6hhv6778fxwsz4hvarbm97dsb8jj0mg7a9qs273r35pqck"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f
@@ -2869,15 +2869,7 @@ PGP handling, multiple servers, and secure connections.")
"CC=gcc")
#:phases
(modify-phases %standard-phases
- (delete 'configure)
- (add-after 'unpack 'fix-include-path
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((pcre (assoc-ref inputs "pcre")))
- (substitute* "src/Makefile"
- (("INCDIRS =")
- (string-append "INCDIRS ="
- "-I" pcre "/include")))
- #t))))))
+ (delete 'configure)))) ; no configure script
(native-inputs
`(("lua" ,lua)
("pcre" ,pcre)