summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-03-22 12:57:37 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-03-22 12:57:37 +0200
commit378de69c59ee0700c67b10b38592c213821b41f2 (patch)
treeee9b6465430077a79cace3cb8fab1a85a8c1e4c5 /gnu/packages/mail.scm
parent049e02eaa258942515260a58c8d9ddfc4e7caffe (diff)
parentd8be338f16c7da4acfa55f29f58beaf908d3ad60 (diff)
downloadpatches-378de69c59ee0700c67b10b38592c213821b41f2.tar
patches-378de69c59ee0700c67b10b38592c213821b41f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm54
1 files changed, 51 insertions, 3 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index f387204d06..369fb69d9b 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
;;; Copyright © 2016, 2017 <contact.ng0@cryptolab.net>
;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
-;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016, 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
@@ -423,8 +423,7 @@ and corrections. It is based on a Bayesian filter.")
"0i5dvygps1ai2qwgamab8kngrp0c5m3bgaw0jk34l8ypsk54wj8r"))))
(build-system python-build-system)
(native-inputs
- `(("asciidoc" ,asciidoc)
- ("libxslt" ,libxslt))) ; for xsltproc
+ `(("asciidoc" ,asciidoc)))
(inputs `(("python2-pysqlite" ,python2-pysqlite)
("python2-six" ,python2-six)))
(arguments
@@ -2099,3 +2098,52 @@ indexed mbox files. There are two programs: @code{bindex} and @code{bit}.
are supported). @code{bit} is a CGI/SSI program that generates web pages
on the fly. Both programs are written in C and are very fast.")
(license license:expat)))
+
+(define-public swaks
+ (package
+ (name "swaks")
+ (version "20170101.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://jetmore.org/john/code/swaks/files/swaks-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0pli4mlhasnqqxmmxalwyg3x7n2vhcbgsnp2xgddamjavv82vrl4"))))
+ (build-system perl-build-system)
+ (inputs
+ `(("perl-net-dns" ,perl-net-dns)
+ ("perl-net-ssleay" ,perl-net-ssleay)))
+ (arguments
+ `(#:tests? #f ; No tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda _
+ (zero? (system* "pod2man" "doc/ref.pod" "swaks.1"))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (install-file "swaks" (string-append out "/bin"))
+ (install-file "swaks.1" (string-append out "/share/man/man1")))
+ #t))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (wrap-program (string-append (assoc-ref outputs "out")
+ "/bin/swaks")
+ `("PERL5LIB" ":" = (,(getenv "PERL5LIB"))))
+ #t)))))
+ (home-page "http://jetmore.org/john/code/swaks/")
+ (synopsis "Featureful SMTP test tool")
+ (description "Swaks is a flexible, scriptable, transaction-oriented SMTP
+test tool. It handles SMTP features and extensions such as TLS,
+authentication, and pipelining; multiple versions of the SMTP protocol
+including SMTP, ESMTP, and LMTP; and multiple transport methods including
+unix-domain sockets, internet-domain sockets, and pipes to spawned processes.
+Options can be specified in environment variables, configuration files, and
+the command line allowing maximum configurability and ease of use for
+operators and scripters.")
+ (license gpl2+)))