summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-02 22:35:05 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-02 22:35:26 +0100
commitd54a759d2b1fce3b57cfacfcd78a6e74baced6d3 (patch)
tree66f387ce94c9bab9c6fee46c677a15ee097ec9b6 /gnu/packages/mail.scm
parent4a7f132240266fa75bd99e5d4198667bed47bfb7 (diff)
downloadpatches-d54a759d2b1fce3b57cfacfcd78a6e74baced6d3.tar
patches-d54a759d2b1fce3b57cfacfcd78a6e74baced6d3.tar.gz
gnu: neomutt: Update to 20191102.
* gnu/packages/mail.scm (neomutt): Update to 20191102.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm185
1 files changed, 91 insertions, 94 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index f753e3756f..3a9eada1f7 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -399,101 +399,98 @@ operating systems.")
(license gpl2+)))
(define-public neomutt
- (let ((tag "2019-10-25"))
- (package
- (name "neomutt")
- ;; Upstream now uses YYYY-MM-DD instead of YYYYMMDD, but we're forever
- ;; wed to the latter through ‘guix upgrade’.
- (version (apply string-append (string-split tag #\-)))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/neomutt/neomutt.git")
- (commit tag)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0hy6rxgm3acjqxpf4ss7391kps4g06fbjhbpgv1jdrj1y9kv0rm1"))))
- (build-system gnu-build-system)
- (inputs
- `(("cyrus-sasl" ,cyrus-sasl)
- ("gdbm" ,gdbm)
- ("gpgme" ,gpgme)
- ("ncurses" ,ncurses)
- ("gnutls" ,gnutls)
- ("openssl" ,openssl) ; for S/MIME
- ("perl" ,perl)
- ("kyotocabinet" ,kyotocabinet)
- ("libxslt" ,libxslt)
- ("libidn2" ,libidn2)
- ("libxml2" ,libxml2)
- ("lmdb" ,lmdb)
- ("notmuch" ,notmuch)))
- (native-inputs
- `(("automake" ,automake)
- ("gettext-minimal" ,gettext-minimal)
- ("pkg-config" ,pkg-config)
- ("docbook-xsl" ,docbook-xsl)
- ("docbook-xml" ,docbook-xml-4.2)
- ("w3m" ,w3m)
- ("tcl" ,tcl)))
- (arguments
- `(#:test-target "test"
- #:configure-flags
- (list "--gpgme"
-
- ;; Database, implies header caching.
- "--disable-tokyocabinet"
- "--disable-qdbm"
- "--disable-bdb"
- "--lmdb"
- "--kyotocabinet"
-
- "--gdbm"
-
- "--gnutls"
- "--disable-ssl"
- "--sasl"
- (string-append "--with-sasl="
- (assoc-ref %build-inputs "cyrus-sasl"))
-
-
- "--smime"
- "--notmuch"
- "--disable-idn"
- "--idn2"
-
- ;; If we do not set this, neomutt wants to check
- ;; whether the path exists, which it does not
- ;; in the chroot.
- "--with-mailpath=/var/mail"
-
- "--with-ui=ncurses"
- (string-append "--with-ncurses="
- (assoc-ref %build-inputs "ncurses"))
- (string-append "--prefix="
- (assoc-ref %outputs "out"))
- "--debug")
- #:phases
- (modify-phases %standard-phases
- ;; TODO: autosetup is meant to be included in the source,
- ;; but we should package autosetup and use our own version of it.
- (replace 'configure
- (lambda* (#:key outputs inputs configure-flags #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (flags `(,@configure-flags))
- (bash (which "bash")))
- (setenv "SHELL" bash)
- (setenv "CONFIG_SHELL" bash)
- (apply invoke bash
- (string-append (getcwd) "/configure")
- flags)))))))
- (home-page "https://www.neomutt.org/")
- (synopsis "Command-line mail reader based on Mutt")
- (description
- "NeoMutt is a command-line mail reader which is based on mutt.
+ (package
+ (name "neomutt")
+ (version "20191102")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/neomutt/neomutt.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0x5f9zbvxsxg5y2ir4xq4xw1q2snaxkidhdyhcxw5ljw3qqwhlyq"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("cyrus-sasl" ,cyrus-sasl)
+ ("gdbm" ,gdbm)
+ ("gpgme" ,gpgme)
+ ("ncurses" ,ncurses)
+ ("gnutls" ,gnutls)
+ ("openssl" ,openssl) ; for S/MIME
+ ("perl" ,perl)
+ ("kyotocabinet" ,kyotocabinet)
+ ("libxslt" ,libxslt)
+ ("libidn2" ,libidn2)
+ ("libxml2" ,libxml2)
+ ("lmdb" ,lmdb)
+ ("notmuch" ,notmuch)))
+ (native-inputs
+ `(("automake" ,automake)
+ ("gettext-minimal" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)
+ ("docbook-xsl" ,docbook-xsl)
+ ("docbook-xml" ,docbook-xml-4.2)
+ ("w3m" ,w3m)
+ ("tcl" ,tcl)))
+ (arguments
+ `(#:test-target "test"
+ #:configure-flags
+ (list "--gpgme"
+
+ ;; Database, implies header caching.
+ "--disable-tokyocabinet"
+ "--disable-qdbm"
+ "--disable-bdb"
+ "--lmdb"
+ "--kyotocabinet"
+
+ "--gdbm"
+
+ "--gnutls"
+ "--disable-ssl"
+ "--sasl"
+ (string-append "--with-sasl="
+ (assoc-ref %build-inputs "cyrus-sasl"))
+
+
+ "--smime"
+ "--notmuch"
+ "--disable-idn"
+ "--idn2"
+
+ ;; If we do not set this, neomutt wants to check
+ ;; whether the path exists, which it does not
+ ;; in the chroot.
+ "--with-mailpath=/var/mail"
+
+ "--with-ui=ncurses"
+ (string-append "--with-ncurses="
+ (assoc-ref %build-inputs "ncurses"))
+ (string-append "--prefix="
+ (assoc-ref %outputs "out"))
+ "--debug")
+ #:phases
+ (modify-phases %standard-phases
+ ;; TODO: autosetup is meant to be included in the source,
+ ;; but we should package autosetup and use our own version of it.
+ (replace 'configure
+ (lambda* (#:key outputs inputs configure-flags #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (flags `(,@configure-flags))
+ (bash (which "bash")))
+ (setenv "SHELL" bash)
+ (setenv "CONFIG_SHELL" bash)
+ (apply invoke bash
+ (string-append (getcwd) "/configure")
+ flags)))))))
+ (home-page "https://www.neomutt.org/")
+ (synopsis "Command-line mail reader based on Mutt")
+ (description
+ "NeoMutt is a command-line mail reader which is based on mutt.
It adds a large amount of new and improved features to mutt.")
- (license gpl2+))))
+ (license gpl2+)))
(define-public gmime
(package