summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-08-15 22:23:59 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-08-16 15:35:05 -0400
commiteb537f5748a1218fa9432d2da6101d7971f529f1 (patch)
tree9e20ff3aee00e4fe87b5a96bde795dd78026d4bd /gnu/packages/mail.scm
parent07cd148c7a6c45742227d31e9854dde066982843 (diff)
downloadpatches-eb537f5748a1218fa9432d2da6101d7971f529f1.tar
patches-eb537f5748a1218fa9432d2da6101d7971f529f1.tar.gz
gnu: notmuch: Update to 0.20.2.
* gnu/packages/mail.scm (notmuch): Update to 0.20.2. Add python-sphinx native input. Rewrite phases using 'modify-phases' syntax.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm33
1 files changed, 14 insertions, 19 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 0b27211cc7..6e0cfdfd32 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -365,36 +365,31 @@ attachments, create new maildirs, and so on.")
(define-public notmuch
(package
(name "notmuch")
- (version "0.19")
+ (version "0.20.2")
(source (origin
(method url-fetch)
(uri (string-append "http://notmuchmail.org/releases/notmuch-"
version ".tar.gz"))
(sha256
(base32
- "1szf6c44g209pcjq5nvfhlp3nzcm3lrcwv4spsxmwy13hiaccvrr"))))
+ "1v5dcnlg4km5hfaq0i0qywq5fn66fi0rq4aaibyqkwxz8mis4hgp"))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ;; FIXME: Test suite hangs and times out.
- #:phases (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "CC" "gcc")
- (setenv "CONFIG_SHELL" (which "sh"))
-
- ;; XXX Should python-docutils make a symlink
- ;; for "rst2man" and other similar programs?
- (substitute* '("configure" "doc/prerst2man.py")
- ((" rst2man ") " rst2man.py "))
-
- (let ((out (assoc-ref outputs "out")))
- (zero? (system* "./configure"
- (string-append "--prefix=" out)))))
- %standard-phases)))
+ '(#:tests? #f ;; FIXME: 637 tests; 70 fail and 98 are skipped
+ #:phases (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (setenv "CC" "gcc")
+ (setenv "CONFIG_SHELL" (which "sh"))
+
+ (let ((out (assoc-ref outputs "out")))
+ (zero? (system* "./configure"
+ (string-append "--prefix=" out)))))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("python" ,python-2)
- ("python2-docutils" ,python2-docutils)
+ ("python-docutils" ,python2-docutils)
+ ("python-sphinx" ,python2-sphinx)
("bash-completion" ,bash-completion)))
(inputs
`(("emacs" ,emacs)