summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-11-16 21:00:40 +0800
committer宋文武 <iyzsong@gmail.com>2016-11-16 21:00:40 +0800
commiteb4b3e4bef412647e1c2756123b8a687996a04e1 (patch)
tree2ee519a8a2b58c5e03b43935a1846313941c89e7 /gnu/packages/mail.scm
parentd55019136eb8d3df39d499e9e5c486473f140235 (diff)
downloadpatches-eb4b3e4bef412647e1c2756123b8a687996a04e1.tar
patches-eb4b3e4bef412647e1c2756123b8a687996a04e1.tar.gz
gnu: opensmtpd: Update to 6.0.2p1.
* gnu/packages/mail.scm (opensmtpd): Update to 6.0.2p1. [arguments]: Pass '--with-path-sock=/var/run' to #:configure-flags.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index a485c1f5c3..5d304d5c8f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1605,14 +1605,14 @@ transfer protocols.")
(define-public opensmtpd
(package
(name "opensmtpd")
- (version "5.9.2p1")
+ (version "6.0.2p1")
(source (origin
(method url-fetch)
(uri (string-append "https://www.opensmtpd.org/archives/"
name "-" version ".tar.gz"))
(sha256
(base32
- "07d7f1m5sxyz6mkk228rcm7fsf7350994ayvmhgph333q5rz48im"))))
+ "1b4h64w45hpmfq5721smhg4s0shs64gbcjqjpx3fbiw4hz8bdy9a"))))
(build-system gnu-build-system)
(inputs
`(("bdb" ,bdb)
@@ -1626,7 +1626,8 @@ transfer protocols.")
(arguments
`(#:configure-flags (list "--with-table-db" "--localstatedir=/var"
"--with-user-smtpd=smtpd" "--with-user-queue=smtpq"
- "--with-group-queue=smtpq")
+ "--with-group-queue=smtpq"
+ "--with-path-socket=/var/run")
#:phases
(modify-phases %standard-phases
;; OpenSMTPD provides a single utility smtpctl to control the daemon and