summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-05-17 02:27:27 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-17 02:52:56 +0200
commitd28692a7b512d1d0a2e6b48aa83095f373969abd (patch)
tree510cbca15b2f28662553188d402d84de16ef7701 /gnu/packages/mail.scm
parent5dd8cb2ec3488edd7fcd1371c188403cc28c7d42 (diff)
downloadpatches-d28692a7b512d1d0a2e6b48aa83095f373969abd.tar
patches-d28692a7b512d1d0a2e6b48aa83095f373969abd.tar.gz
gnu: alpine: Update to 2.22.
* gnu/packages/mail.scm (alpine): Update to 2.22. [arguments]: Add ‘assume-shadow-passwords’ phase.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index ca1828b1b1..6e39dc2d15 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2681,7 +2681,7 @@ operators and scripters.")
;; Upstream doesn't use git tags, but does ‘tag’ their releases in the
;; commit message. Hence the lack of GIT-VERSIONing despite using a commit
;; ID below. Don't forget to update it…
- (version "2.21.99999")
+ (version "2.22")
(source
(origin
(method git-fetch)
@@ -2691,10 +2691,10 @@ operators and scripters.")
;; http://alpine.freeiz.com/alpine/readme/README.patches
(uri (git-reference
(url "http://repo.or.cz/alpine.git")
- (commit "abeb2c25935ef8c75f1e5deef0f81276754dc975")))
+ (commit "b50297779a4becb9ceca9c6b5b375d526fe3df78")))
(file-name (git-file-name name version))
(sha256
- (base32 "0rqgbw08a5lj41dkp82aq480lqkc4bnxagna7wpqffi821n8gkwz"))
+ (base32 "06js44fvdl7l33hfd4lsxpcd1cz3c0h796cswyzz0lkrzx89yl48"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -2720,6 +2720,13 @@ operators and scripters.")
"--with-date-stamp=Thu 1 Jan 01:00:01 CET 1970")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'assume-shadow-passwords
+ ;; Alpine's configure script confuses ‘shadow password support’ with
+ ;; ‘/etc/shadow exists in the build environment’. It does not.
+ (lambda _
+ (substitute* "configure"
+ (("test -f /etc/shadow") "true"))
+ #t))
(add-after 'unpack 'make-reproducible
(lambda _
;; This removes time-dependent code to make alpine reproducible.