summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-20 21:53:50 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-21 00:26:14 +0200
commit7373eb8304e0ebbfabe66deb59e78187013403dd (patch)
treefa2d8a3b2731a85b9d2df2887280bcb22536a348 /gnu/packages/machine-learning.scm
parentbd1213708cb4d10b3a9bb633a2b21dc82f39f98b (diff)
downloadpatches-7373eb8304e0ebbfabe66deb59e78187013403dd.tar
patches-7373eb8304e0ebbfabe66deb59e78187013403dd.tar.gz
gnu: protobuf: Update to 3.10.0.
* gnu/packages/protobuf.scm (protobuf, python-protobuf): Update to 3.10.0. (protobuf-next, python-protobuf-next): Rename to .... (protobuf-3.6, python-protobuf-3.6): ... this. (protobuf-3.5): New public variable. * gnu/packages/machine-learning.scm (grpc)[native-inputs]: Change from PROTOBUF-NEXT to PROTOBUF. (tensorflow)[native-inputs, propagated-inputs]: Adjust for renamed PROTOBUF-NEXT. * gnu/packages/robotics.scm (aseba)[inputs]: Change from PROTOBUF to PROTOBUF-3.5. * gnu/packages/telephony.scm (mumble)[inputs]: Likewise.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 254ee59c4a..2b2df6da6a 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1302,7 +1302,7 @@ Python.")
("openssl" ,openssl)
("zlib" ,zlib)))
(native-inputs
- `(("protobuf" ,protobuf-next)
+ `(("protobuf" ,protobuf)
("python" ,python-wrapper)))
(home-page "https://grpc.io")
(synopsis "High performance universal RPC framework")
@@ -1607,8 +1607,8 @@ INSTALL_RPATH " (assoc-ref outputs "out") "/lib)\n")))
#t))))))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("protobuf:native" ,protobuf-next) ; protoc
- ("protobuf:src" ,(package-source protobuf-next))
+ ("protobuf:native" ,protobuf-3.6) ; protoc
+ ("protobuf:src" ,(package-source protobuf-3.6))
("eigen:src" ,(package-source eigen-for-tensorflow))
;; install_pip_packages.sh wants setuptools 39.1.0 specifically.
("python-setuptools" ,python-setuptools-for-tensorflow)
@@ -1735,7 +1735,7 @@ INSTALL_RPATH " (assoc-ref outputs "out") "/lib)\n")))
("python-gast" ,python-gast)
("python-grpcio" ,python-grpcio)
("python-numpy" ,python-numpy)
- ("python-protobuf" ,python-protobuf-next)
+ ("python-protobuf" ,python-protobuf-3.6)
("python-six" ,python-six)
("python-termcolo" ,python-termcolor)
("python-wheel" ,python-wheel)))
@@ -1751,7 +1751,7 @@ INSTALL_RPATH " (assoc-ref outputs "out") "/lib)\n")))
("jsoncpp" ,jsoncpp-for-tensorflow)
("snappy" ,snappy)
("sqlite" ,sqlite)
- ("protobuf" ,protobuf-next)
+ ("protobuf" ,protobuf-3.6)
("python" ,python-wrapper)
("zlib" ,zlib)))
(home-page "https://tensorflow.org")