summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-08-08 00:35:37 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-08-08 00:35:37 +0200
commit8e7f97b9ffee10af3cf16958ebc0a7d410a19ca8 (patch)
treeb3836f9cea849fd8bfb61a77ba225a0054babe58 /gnu/packages/machine-learning.scm
parentfa228db78bc9dcb0e7da607dd8783224c76d7ef5 (diff)
parentba7ff983d613f735ee270f0b0e3c5dba5cbeda3c (diff)
downloadpatches-8e7f97b9ffee10af3cf16958ebc0a7d410a19ca8.tar
patches-8e7f97b9ffee10af3cf16958ebc0a7d410a19ca8.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 2dc7dc81ef..e48c91a2cf 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -193,7 +193,7 @@ classification.")
(uri (svn-reference
(url "http://svn.code.sf.net/p/ghmm/code/trunk")
(revision svn-revision)))
- (file-name (string-append name "-" version))
+ (file-name (string-append name "-" version "-checkout"))
(sha256
(base32
"0qbq1rqp94l530f043qzp8aw5lj7dng9wq0miffd7spd1ff638wq"))))
@@ -251,10 +251,7 @@ classification.")
(string-append indent
"@unittest.skip(\"Disabled by Guix\")\n"
line)))
- #t))
- (add-after 'disable-broken-tests 'autogen
- (lambda _
- (invoke "bash" "autogen.sh"))))))
+ #t)))))
(inputs
`(("python" ,python-2) ; only Python 2 is supported
("libxml2" ,libxml2)))
@@ -821,8 +818,14 @@ computing environments.")
(setenv "HOME" "/tmp")
(invoke "pytest" "sklearn" "-m" "not network")))
- ;; FIXME: This fails with permission denied
- (delete 'reset-gzip-timestamps))))
+ (add-before 'reset-gzip-timestamps 'make-files-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Make sure .gz files are writable so that the
+ ;; 'reset-gzip-timestamps' phase can do its work.
+ (let ((out (assoc-ref outputs "out")))
+ (for-each make-file-writable
+ (find-files out "\\.gz$"))
+ #t))))))
(inputs
`(("openblas" ,openblas)))
(native-inputs