summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo@riseup.net>2019-03-13 23:37:30 +0800
committerDanny Milosavljevic <dannym@scratchpost.org>2019-03-14 16:47:18 +0100
commit3b7348c4dc17df8198956225082162cc49b72899 (patch)
treebf5af290327a46bd14161bdf426575a0b8213459 /gnu/packages/lxqt.scm
parent536afd9bf27a3b45096cb7c442d4e9bfcf23e8b3 (diff)
downloadpatches-3b7348c4dc17df8198956225082162cc49b72899.tar
patches-3b7348c4dc17df8198956225082162cc49b72899.tar.gz
gnu: lxqt-sudo: Update to 0.14.1.
* gnu/packages/lxqt.scm (lxqt-sudo): Update to 0.14.1. [arguments]: Remove #:configure-flags. <#:phases>[patch-translations-dir]: New phase. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 005096716b..f8814f4b7b 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -841,14 +841,14 @@ for the LXQt desktop environment.")
(define-public lxqt-sudo
(package
(name "lxqt-sudo")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1j28wlw4rkzvr85yl78fqkvz7sv7dykm9ghm63xdkskfjbsas1cf"))))
+ (base32 "0mbygp2kkppwk7sxvpnwavdwrx88mh7ldcg6xm3zw1ndp29danay"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -864,9 +864,15 @@ for the LXQt desktop environment.")
("lxqt-build-tools" ,lxqt-build-tools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-translations-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/lxqt/translations")))
+ #t)))))
(home-page "https://lxqt.org/")
(synopsis "GUI frontend for sudo/su")
(description "lxqt-sudo is a graphical front-end of commands sudo and su