summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-10-20 10:50:40 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-26 22:07:04 +0800
commit097166dfb05ca7ea6eb3b7a10cdd356353819f35 (patch)
treef8f9106dc909c6597601d0ef7bed399837849346 /gnu/packages/lxqt.scm
parent31fd62c8ca5131833d980a5f5e90d013ac842f31 (diff)
downloadpatches-097166dfb05ca7ea6eb3b7a10cdd356353819f35.tar
patches-097166dfb05ca7ea6eb3b7a10cdd356353819f35.tar.gz
gnu: lxqt.scm: Remove ${CMAKE_INSTALL_PREFIX} from DESTINATION path.
* gnu/packages/lxqt.scm: Remove ${CMAKE_INSTALL_PREFIX} from DESTINATION path. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 76fe01be46..38330dd976 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -200,7 +200,7 @@ in Qt.")
(lambda _
(substitute* "CMakeLists.txt"
(("DESTINATION \"\\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
- "DESTINATION \"${CMAKE_INSTALL_PREFIX}/share/polkit-1/actions"))
+ "DESTINATION \"share/polkit-1/actions"))
#t)))))
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -310,7 +310,7 @@ LXQt and the system it's running on.")
(lambda _
(substitute* "lxqt-admin-user/CMakeLists.txt"
(("DESTINATION \"\\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
- "DESTINATION \"${CMAKE_INSTALL_PREFIX}/share/polkit-1/actions"))
+ "DESTINATION \"share/polkit-1/actions"))
#t)))))
(home-page "https://lxqt.org")
(synopsis "LXQt system administration tool")
@@ -356,7 +356,7 @@ the operating system LXQt is running on.")
(lambda _
(substitute* '("src/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
- "DESTINATION \"${CMAKE_INSTALL_PREFIX}/etc/xdg"))
+ "DESTINATION \"etc/xdg"))
#t)))))
(home-page "https://lxqt.org")
(synopsis "Tools to configure LXQt and the underlying operating system")
@@ -399,7 +399,7 @@ configuration of both LXQt and the underlying operating system.")
(substitute* '("autostart/CMakeLists.txt"
"xdg/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
- "DESTINATION \"${CMAKE_INSTALL_PREFIX}/etc/xdg"))
+ "DESTINATION \"etc/xdg"))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "Daemon used to register global keyboard shortcuts")
@@ -441,7 +441,7 @@ as a whole and are not limited to distinct applications.")
(lambda _
(substitute* '("autostart/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
- "DESTINATION \"${CMAKE_INSTALL_PREFIX}/etc/xdg"))
+ "DESTINATION \"etc/xdg"))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "The LXQt notification daemon")
@@ -532,7 +532,7 @@ of other programs.")
(substitute* '("autostart/CMakeLists.txt"
"menu/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
- "DESTINATION \"${CMAKE_INSTALL_PREFIX}/etc/xdg"))
+ "DESTINATION \"etc/xdg"))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "The LXQt desktop panel")
@@ -575,7 +575,7 @@ of other programs.")
(lambda _
(substitute* '("autostart/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
- "DESTINATION \"${CMAKE_INSTALL_PREFIX}/etc/xdg"))
+ "DESTINATION \"etc/xdg"))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "The LXQt PolicyKit agent")
@@ -618,7 +618,7 @@ LXQt.")
(lambda _
(substitute* '("autostart/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
- "DESTINATION \"${CMAKE_INSTALL_PREFIX}/etc/xdg"))
+ "DESTINATION \"etc/xdg"))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "Power management module for LXQt")
@@ -657,7 +657,7 @@ when laptop batteries are low on power.")
(lambda _
(substitute* '("src/CMakeLists.txt")
(("DESTINATION \"\\$\\{QT_PLUGINS_DIR\\}")
- "DESTINATION \"${CMAKE_INSTALL_PREFIX}/lib/qt5/plugins"))
+ "DESTINATION \"lib/qt5/plugins"))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "LXQt Qt platform integration plugin")
@@ -702,7 +702,7 @@ Qt with LXQt.")
(lambda _
(substitute* '("autostart/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
- "DESTINATION \"${CMAKE_INSTALL_PREFIX}/etc/xdg"))
+ "DESTINATION \"etc/xdg"))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "Tool used to launch programs quickly by typing their names")
@@ -746,7 +746,7 @@ allows for launching applications or shutting down the system.")
(substitute* '("autostart/CMakeLists.txt"
"config/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
- "DESTINATION \"${CMAKE_INSTALL_PREFIX}/etc/xdg"))
+ "DESTINATION \"etc/xdg"))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "Session manager for LXQt")
@@ -812,10 +812,10 @@ permissions of other users including root.")
(lambda _
(substitute* '("CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_GRAPHICS_DIR\\}")
- "DESTINATION \"${CMAKE_INSTALL_PREFIX}/share/lxqt/graphics"))
+ "DESTINATION \"share/lxqt/graphics"))
(substitute* '("themes/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_SHARE_DIR\\}")
- "DESTINATION \"${CMAKE_INSTALL_PREFIX}/share/lxqt"))
+ "DESTINATION \"share/lxqt"))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "Themes, graphics and icons for LXQt")
@@ -895,7 +895,7 @@ components to build desktop file managers which belongs to LXDE.")
(lambda _
(substitute* '("autostart/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
- "DESTINATION \"${CMAKE_INSTALL_PREFIX}/etc/xdg"))
+ "DESTINATION \"etc/xdg"))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "File manager and desktop icon manager")
@@ -936,7 +936,7 @@ LXDE.")
(lambda _
(substitute* '("autostart/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
- "DESTINATION \"${CMAKE_INSTALL_PREFIX}/etc/xdg"))
+ "DESTINATION \"etc/xdg"))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "GUI configuration tool for compton X composite manager")