summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-10-18 10:38:24 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-23 21:37:48 +0800
commitd58aefdf06586365e0cc9f832e40fe6c5fddb1e3 (patch)
tree670175aafbdce5d3a02bca22e3e83d718ced7795 /gnu/packages/lxqt.scm
parent088096aa0e0567a1d3d666322c3e919069216261 (diff)
downloadpatches-d58aefdf06586365e0cc9f832e40fe6c5fddb1e3.tar
patches-d58aefdf06586365e0cc9f832e40fe6c5fddb1e3.tar.gz
gnu: lxqt.scm: Sort packages alphabetically.
* gnu/packages/lxqt.scm: Sort packages alphabetically. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm116
1 files changed, 58 insertions, 58 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 49a7040bcc..dda4dd8b0f 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -38,6 +38,48 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages xorg))
+(define-public liblxqt
+ (package
+ (name "liblxqt")
+ (version "0.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/lxqt/" name "/releases/download/"
+ version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32 "0fba0nq5b9fvvmklcikcd4nwhzlp5d6k1q1f80r34kncdzfvj7dl"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:configure-flags
+ ;; TODO: prefetch translations files from 'lxqt-l10n'.
+ '("-DPULL_TRANSLATIONS=NO")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("DESTINATION \"\\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
+ "DESTINATION \"${CMAKE_INSTALL_PREFIX}/share/polkit-1/actions"))
+ #t)))))
+ (inputs
+ `(("kwindowsystem" ,kwindowsystem)
+ ("libqtxdg" ,libqtxdg)
+ ("libxscrnsaver" ,libxscrnsaver)
+ ("polkit-qt" ,polkit-qt)
+ ("qtsvg" ,qtsvg)
+ ("qttools" ,qttools)
+ ("qtx11extras" ,qtx11extras)))
+ (native-inputs
+ `(("lxqt-build-tools" ,lxqt-build-tools)))
+ (home-page "https://lxqt.org/")
+ (synopsis "Core utility library for all LXQt components")
+ (description "liblxqt provides the basic libraries shared by the
+components of the LXQt desktop environment.")
+ (license lgpl2.1+)))
+
(define-public libqtxdg
(package
(name "libqtxdg")
@@ -73,46 +115,30 @@
in Qt.")
(license lgpl2.1+)))
-(define-public liblxqt
+(define-public lxqt-build-tools
(package
- (name "liblxqt")
- (version "0.13.0")
+ (name "lxqt-build-tools")
+ (version "0.5.0")
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://github.com/lxqt/" name "/releases/download/"
- version "/" name "-" version ".tar.xz"))
+ (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
+ version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0fba0nq5b9fvvmklcikcd4nwhzlp5d6k1q1f80r34kncdzfvj7dl"))))
+ (base32 "13b5x26p6ycnwzlgg1cgvlc88wjrjmlb3snrrmzh0xgh9h6hhvd6"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-source
- (lambda _
- (substitute* "CMakeLists.txt"
- (("DESTINATION \"\\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
- "DESTINATION \"${CMAKE_INSTALL_PREFIX}/share/polkit-1/actions"))
- #t)))))
- (inputs
- `(("kwindowsystem" ,kwindowsystem)
- ("libqtxdg" ,libqtxdg)
- ("libxscrnsaver" ,libxscrnsaver)
- ("polkit-qt" ,polkit-qt)
- ("qtsvg" ,qtsvg)
- ("qttools" ,qttools)
- ("qtx11extras" ,qtx11extras)))
+ `(#:tests? #f)) ; no tests
(native-inputs
- `(("lxqt-build-tools" ,lxqt-build-tools)))
- (home-page "https://lxqt.org/")
- (synopsis "Core utility library for all LXQt components")
- (description "liblxqt provides the basic libraries shared by the
-components of the LXQt desktop environment.")
+ `(("pkg-config" ,pkg-config)
+ ("glib" ,glib)))
+ (inputs
+ `(("qtbase" ,qtbase)))
+ (synopsis "LXQt Build tools")
+ (description
+ "Lxqt-build-tools is providing several tools needed to build LXQt
+itself as well as other components maintained by the LXQt project.")
+ (home-page "https://lxqt.org")
(license lgpl2.1+)))
(define-public lxqt-session
@@ -158,29 +184,3 @@ components of the LXQt desktop environment.")
(description "lxqt-session provides the standard session manager
for the LXQt desktop environment.")
(license lgpl2.1+)))
-
-(define-public lxqt-build-tools
- (package
- (name "lxqt-build-tools")
- (version "0.5.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
- version "/" name "-" version ".tar.xz"))
- (sha256
- (base32 "13b5x26p6ycnwzlgg1cgvlc88wjrjmlb3snrrmzh0xgh9h6hhvd6"))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f)) ; no tests
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("glib" ,glib)))
- (inputs
- `(("qtbase" ,qtbase)))
- (synopsis "LXQt Build tools")
- (description
- "Lxqt-build-tools is providing several tools needed to build LXQt
-itself as well as other components maintained by the LXQt project.")
- (home-page "https://lxqt.org")
- (license lgpl2.1+)))