summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo@riseup.net>2019-03-13 23:37:18 +0800
committerDanny Milosavljevic <dannym@scratchpost.org>2019-03-14 16:47:17 +0100
commitf42b4080c3fca7b0fe9cfc397280bb9b3b1676d7 (patch)
tree50bfd1a92ffec10e8c03b3349bd332dc6248a401 /gnu/packages/lxqt.scm
parent4c3553ab4139dbdbb3998319e8a1f20bbfbe6413 (diff)
downloadpatches-f42b4080c3fca7b0fe9cfc397280bb9b3b1676d7.tar
patches-f42b4080c3fca7b0fe9cfc397280bb9b3b1676d7.tar.gz
gnu: lxqt-about: Update to 0.14.1.
* gnu/packages/lxqt.scm (lxqt-about): Update to 0.14.1. [arguments]: Remove #:configure-flags. <#:phases>[patch-translations-dir]: New phase. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 2dcaa5dd8d..f09b162412 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -265,14 +265,14 @@ and memory usage or network traffic.")
(define-public lxqt-about
(package
(name "lxqt-about")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "08imj7p77ifzfxnn8c482mhrvfx9gi0rb43ab5rw1rkmfvax2n5w"))))
+ (base32 "01xp5ddcxc9wvl7jm4179hjrirj07mpzm9z50936d1fqx34wfbis"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -286,9 +286,15 @@ and memory usage or network traffic.")
("qttools" ,qttools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-translations-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/lxqt/translations")))
+ #t)))))
(home-page "https://lxqt.org")
(synopsis "Provides information about LXQt and the system")
(description "lxqt-about is a dialogue window providing information about