summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo@riseup.net>2019-03-13 23:37:28 +0800
committerDanny Milosavljevic <dannym@scratchpost.org>2019-03-14 16:47:18 +0100
commit1b8daca27b60d5d311cc72d16519662046f679e7 (patch)
treea38b7ea041c85305418282c869682e11205410e1 /gnu/packages/lxqt.scm
parent63c80bd7a94137c803510a7868a687c3f689917e (diff)
downloadpatches-1b8daca27b60d5d311cc72d16519662046f679e7.tar
patches-1b8daca27b60d5d311cc72d16519662046f679e7.tar.gz
gnu: lxqt-runner: Update to 0.14.1.
* gnu/packages/lxqt.scm (lxqt-runner): Update to 0.14.1. [arguments]: Remove #:configure-flags. <#:phases>[patch-translations-dir]: New phase. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index bc5cd72c0c..606bddaf7e 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -741,14 +741,14 @@ Qt with LXQt.")
(define-public lxqt-runner
(package
(name "lxqt-runner")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0dsg6fdcqbl7gza0sg1pb49zn5x31q7zx77jp7mkf6wc2lv8lali"))))
+ (base32 "1c687shypivkhjrpzs1jcy5l2i8d7xzm31c4is1xx6x9nbkgm4bm"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -766,9 +766,6 @@ Qt with LXQt.")
("lxqt-build-tools" ,lxqt-build-tools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -776,6 +773,13 @@ Qt with LXQt.")
(substitute* '("autostart/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
+ #t))
+ (add-after 'unpack 'patch-translations-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/lxqt/translations")))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "Tool used to launch programs quickly by typing their names")