summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-10-18 11:19:38 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-24 22:37:24 +0800
commitd6fd4a76eb81d2aedaa51a78e29b9b96312d03f9 (patch)
treeb96b30c6f7b5dde15c8cb1519d48697e675ccc10 /gnu/packages/lxqt.scm
parent79f9e4e0b5a43f2517688c291a114ea4211e3d39 (diff)
downloadpatches-d6fd4a76eb81d2aedaa51a78e29b9b96312d03f9.tar
patches-d6fd4a76eb81d2aedaa51a78e29b9b96312d03f9.tar.gz
gnu: Add pcmanfm-qt.
* gnu/packages/lxqt.scm (pcmanfm-qt): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 188eb9dc12..ee48494308 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -488,3 +488,42 @@ for the LXQt desktop environment.")
respectively. As such it enables regular users to launch applications with
permissions of other users including root.")
(license lgpl2.1+)))
+
+(define-public pcmanfm-qt
+ (package
+ (name "pcmanfm-qt")
+ (version "0.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
+ version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32 "08jprkkk62pk34q9lxa207bh27xi86fj8jxfd5z3w2m5j5nim5mz"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("libfm-qt" ,libfm-qt)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("qttools" ,qttools)
+ ("lxqt-build-tools" ,lxqt-build-tools)))
+ (arguments
+ '(#:tests? #f ; no tests
+ #:configure-flags
+ ;; TODO: prefetch translations files from 'lxqt-l10n'.
+ '("-DPULL_TRANSLATIONS=NO")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ (substitute* '("autostart/CMakeLists.txt")
+ (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
+ "DESTINATION \"${CMAKE_INSTALL_PREFIX}/etc/xdg"))
+ #t)))))
+ (home-page "https://lxqt.org/")
+ (synopsis "File manager and desktop icon manager")
+ (description "PCManFM-Qt is the Qt port of PCManFM, the file manager of
+LXDE.")
+ (license lgpl2.1+)))