summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-10-18 18:54:29 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-24 22:37:24 +0800
commitfbe645eafa89f719312a09062172d97eec3078b7 (patch)
treef427b56e1859fa9b51bdb6b1578fbf4868877865 /gnu/packages/lxqt.scm
parentfab3484657e4728496d39bb9d3518ea19412e1cf (diff)
downloadpatches-fbe645eafa89f719312a09062172d97eec3078b7.tar
patches-fbe645eafa89f719312a09062172d97eec3078b7.tar.gz
gnu: Add libsysstat.
* gnu/packages/lxqt.scm (libsysstat): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index a270aff7a9..2d51fec72c 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -171,6 +171,29 @@ to statistics about the system on which it's run.")
;; Libraries are under LGPL2.1+, and programs under GPLv2+.
(license gpl2+)))
+(define-public libsysstat
+ (package
+ (name "libsysstat")
+ (version "0.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
+ version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32 "0ngz8v3bixsdg96d5ipcyxd6nsrg52974xdxy9rnimahlv1yaxn3"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ; no tests
+ (inputs
+ `(("qtbase" ,qtbase)))
+ (native-inputs
+ `(("lxqt-build-tools" ,lxqt-build-tools)))
+ (home-page "https://lxqt.org/")
+ (synopsis "Library used to query system info and statistics")
+ (description "libsysstat is a library to query system information like CPU
+and memory usage or network traffic.")
+ (license lgpl2.1+)))
+
(define-public lxqt-build-tools
(package
(name "lxqt-build-tools")