summaryrefslogtreecommitdiff
path: root/gnu/packages/lxde.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-02 17:31:28 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-02 17:31:28 +0200
commit50e6c1bf2ef2f006baa8cac80dfbb12ca2ba6d64 (patch)
tree64f16d207bad28a9dfda9cce95e6337483a40066 /gnu/packages/lxde.scm
parenta8cb1e72ef351330d1521833c1b270dcc0da593f (diff)
parentafc57916e5398737e13d94b3823983783221eb63 (diff)
downloadpatches-50e6c1bf2ef2f006baa8cac80dfbb12ca2ba6d64.tar
patches-50e6c1bf2ef2f006baa8cac80dfbb12ca2ba6d64.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/lxde.scm')
-rw-r--r--gnu/packages/lxde.scm34
1 files changed, 27 insertions, 7 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 9de96a21cb..a52e403106 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -27,6 +27,7 @@
(define-module (gnu packages lxde)
#:use-module (gnu packages)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
#:use-module (gnu packages disk)
@@ -279,7 +280,6 @@ with freedesktop.org standard.")
`(("bash" ,bash)
("cairo" ,cairo)
("curlftpfs" ,curlftpfs)
- ("dbus" ,dbus)
("eudev" ,eudev)
("fakeroot" ,fakeroot)
("ffmpegthumbnailer" ,ffmpegthumbnailer)
@@ -288,6 +288,7 @@ with freedesktop.org standard.")
("gtk+" ,gtk+)
("ifuse" ,ifuse)
("jmtpfs" ,jmtpfs)
+ ("ktsuss" ,ktsuss)
("libx11" ,libx11)
("lsof" ,lsof)
("pango" ,pango)
@@ -297,12 +298,31 @@ with freedesktop.org standard.")
("util-linux" ,util-linux)
("wget" ,wget)))
(arguments
- `(#:configure-flags (list (string-append "--with-bash-path="
- (assoc-ref %build-inputs "bash")
- "/bin/bash")
- (string-append "--sysconfdir="
- (assoc-ref %outputs "out")
- "/etc"))))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Patch config file to load programs correctly.
+ (substitute* "etc/spacefm.conf"
+ (("#terminal_su=/bin/su")
+ "terminal_su=/run/setuid-programs/sudo")
+ (("#graphical_su=/usr/bin/gksu")
+ (string-append "graphical_su="
+ (string-append (assoc-ref inputs "ktsuss")
+ "/bin/ktsuss"))))
+ ;; SpaceFM expects udevil to have uid set to root.
+ ;; User has to manually add udevil to setuid-programs.
+ (substitute* "src/settings.c"
+ (("/usr/bin/udevil")
+ "/run/setuid-programs/udevil"))
+ #t)))
+ #:configure-flags (list
+ (string-append "--with-bash-path="
+ (assoc-ref %build-inputs "bash")
+ "/bin/bash")
+ (string-append "--sysconfdir="
+ (assoc-ref %outputs "out")
+ "/etc"))))
(home-page "https://ignorantguru.github.io/spacefm/")
(synopsis "Multi-panel tabbed file manager")
(description "SpaceFM is a graphical, multi-panel, tabbed file manager