summaryrefslogtreecommitdiff
path: root/gnu/packages/lsof.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-18 19:32:48 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-19 06:00:29 +0100
commitb7fd3e96c7b6ccf7f6f9949b5a263753b4fee50e (patch)
tree330e0ec6801d2b19b77e2f7058a0b5736279f8fb /gnu/packages/lsof.scm
parent57774ae150dad563767d6d573e206b45fce4683c (diff)
downloadpatches-b7fd3e96c7b6ccf7f6f9949b5a263753b4fee50e.tar
patches-b7fd3e96c7b6ccf7f6f9949b5a263753b4fee50e.tar.gz
gnu: lsof: Update phase style.
* gnu/packages/lsof.scm (lsof)[arguments]: Substitute INVOKE for SYSTEM* and end phases with #t.
Diffstat (limited to 'gnu/packages/lsof.scm')
-rw-r--r--gnu/packages/lsof.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index f9e9759cf2..fcd5c2e1c7 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -69,7 +69,8 @@
(lambda _
(setenv "LSOF_CC" "gcc")
(setenv "LSOF_MAKE" "make")
- (zero? (system* "./Configure" "linux"))))
+ (invoke "./Configure" "linux")
+ #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))