summaryrefslogtreecommitdiff
path: root/gnu/packages/logging.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-22 18:58:48 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-22 18:58:48 +0200
commitccad0e4d6973da7af8badfb7125f35f7e51eb2d7 (patch)
tree15ff9da1c1c03b088d0ad9240f2c1878f5da5802 /gnu/packages/logging.scm
parentd478cc043557ca3fcd5fced87d2e2c8e246eff03 (diff)
parent26986544469ef290885f5f8d71006751e9e8daf8 (diff)
downloadpatches-ccad0e4d6973da7af8badfb7125f35f7e51eb2d7.tar
patches-ccad0e4d6973da7af8badfb7125f35f7e51eb2d7.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/logging.scm')
-rw-r--r--gnu/packages/logging.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 42404636f6..1481f5b5ee 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -75,6 +75,16 @@ staying as close to their API as is reasonable.")
"1xd3maiipfbxmhc9rrblc5x52nxvkwxp14npg31y5njqvkvzax9b"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-before 'check 'disable-signal-tests
+ (lambda _
+ ;; XXX: This test fails on non x86_64. See e.g.
+ ;; https://github.com/google/glog/issues/219 and
+ ;; https://github.com/google/glog/issues/256.
+ (substitute* "Makefile"
+ (("\tsignalhandler_unittest_sh") "\t$(EMPTY)"))
+ #t)))))
(native-inputs
`(("perl" ,perl) ;for tests
("autoconf" ,autoconf-wrapper)