summaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-12-13 13:57:25 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-15 20:43:53 +0000
commitfafa78969eb9a3b5ebaaededc91cab8fc1c208d4 (patch)
treeb28d8d533e91266ef134434d1d032c8e8f360617 /gnu/packages/llvm.scm
parent5b2da2a659bea9a442a36c89be241a1d6c820d45 (diff)
downloadpatches-fafa78969eb9a3b5ebaaededc91cab8fc1c208d4.tar
patches-fafa78969eb9a3b5ebaaededc91cab8fc1c208d4.tar.gz
gnu: llvm-rtti: Remove it.
This reverts commit f8cba3ff4fc6aed0c539700aa47b6e8f4c25c34d. It sounds from the comment that this should be removed now, as it's been a while since this change was made. * gnu/packages/llvm.scm (llvm-without-rtti): Remove it. * gnu/packages/gl.scm (mesa)[inputs]: Switch to using llvm rather than llvm-without-rtti.
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm20
1 files changed, 0 insertions, 20 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 8a9d1d312b..4be86f3d21 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -95,26 +95,6 @@ languages is in development. The compiler infrastructure includes mirror sets
of programming tools as well as libraries with equivalent functionality.")
(license license:ncsa)))
-;; FIXME: This package is here to prevent many rebuilds on x86_64 and i686
-;; from commit fc9dbf41311d99d0fd8befc789ea7c0e35911890. Update users of
-;; this in the next rebuild cycle.
-(define-public llvm-without-rtti
- (package
- (inherit llvm)
- (arguments
- `(#:configure-flags '("-DCMAKE_SKIP_BUILD_RPATH=FALSE"
- "-DCMAKE_BUILD_WITH_INSTALL_RPATH=FALSE"
- "-DBUILD_SHARED_LIBS:BOOL=TRUE"
- "-DLLVM_ENABLE_FFI:BOOL=TRUE"
- "-DLLVM_INSTALL_UTILS=ON")
- #:build-type "Release"
- #:phases (modify-phases %standard-phases
- (add-before 'build 'shared-lib-workaround
- (lambda _
- (setenv "LD_LIBRARY_PATH"
- (string-append (getcwd) "/lib"))
- #t)))))))
-
(define* (clang-runtime-from-llvm llvm hash
#:optional (patches '()))
(package