summaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-07-07 00:06:41 -0500
committerEric Bavier <bavier@member.fsf.org>2016-07-18 20:28:21 -0500
commitac00973cd9aa2051b20bcd27054e00a5467c1218 (patch)
tree1e437ab5c164a5b595c9aea0e8c835c9ceba0a7c /gnu/packages/llvm.scm
parenta53c486dadca8d8a0265ccb32f26d40856a82f05 (diff)
downloadpatches-ac00973cd9aa2051b20bcd27054e00a5467c1218.tar
patches-ac00973cd9aa2051b20bcd27054e00a5467c1218.tar.gz
gnu: llvm: Add "license:" prefix.
* gnu/packages/llvm.scm: Import (guix licenses) with "license:" prefix.
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 3ed60489c1..185dbdab4e 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -20,7 +20,7 @@
(define-module (gnu packages llvm)
#:use-module (guix packages)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (guix download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
@@ -60,7 +60,7 @@ languages. It currently supports compilation of C and C++ programs, using
front-ends derived from GCC 4.0.1. A new front-end for the C family of
languages is in development. The compiler infrastructure includes mirror sets
of programming tools as well as libraries with equivalent functionality.")
- (license ncsa)))
+ (license license:ncsa)))
(define (clang-runtime-from-llvm llvm hash)
(package
@@ -87,7 +87,7 @@ of programming tools as well as libraries with equivalent functionality.")
functions for C and C++ programs. It also provides header files that allow C
and C++ source code to interface with the \"sanitization\" passes of the clang
compiler. In LLVM this library is called \"compiler-rt\".")
- (license ncsa)
+ (license license:ncsa)
;; <http://compiler-rt.llvm.org/> doesn't list MIPS as supported.
(supported-systems (delete "mips64el-linux" %supported-systems))))
@@ -170,7 +170,7 @@ compiler. In LLVM this library is called \"compiler-rt\".")
Objective-C++ programming languages. It uses LLVM as its back end. The Clang
project includes the Clang front end, the Clang static analyzer, and several
code analysis tools.")
- (license ncsa)))
+ (license license:ncsa)))
(define-public clang-runtime
(clang-runtime-from-llvm