summaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2020-04-20 23:56:13 +0200
committerLudovic Courtès <ludo@gnu.org>2020-05-02 16:49:29 +0200
commitb1cb8b5d83dc92734840e9243d084c1c2a604321 (patch)
tree18b4f5f96deef4e1022dc3befbb825289b2b4a46 /gnu/packages/llvm.scm
parent4c0cc7bed3de2c0e2d3a6e95b88693941e839eec (diff)
downloadpatches-b1cb8b5d83dc92734840e9243d084c1c2a604321.tar
patches-b1cb8b5d83dc92734840e9243d084c1c2a604321.tar.gz
gnu: llvm-for-extempore: Update to 3.8.
* gnu/packages/llvm.scm (llvm-for-extempore): Update to 3.8. [source]: Use upstream patched source. * gnu/packages/patches/llvm-for-extempore.patch: Delete due to source being already patched. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index d6c519bcbd..33d863ae11 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2019 Arm Ltd <David.Truby@arm.com>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
+;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -627,12 +628,16 @@ output), and Binutils.")
#:patches '("clang-3.5-libc-search-path.patch")))
(define-public llvm-for-extempore
- (package (inherit llvm-3.7)
+ (package (inherit llvm-3.8)
(name "llvm-for-extempore")
(source
(origin
- (inherit (package-source llvm-3.7))
- (patches (list (search-patch "llvm-for-extempore.patch")))))
+ (method url-fetch)
+ (uri (string-append "http://extempore.moso.com.au/extras/"
+ "llvm-3.8.0.src-patched-for-extempore.tar.xz"))
+ (sha256
+ (base32
+ "1svdl6fxn8l01ni8mpm0bd5h856ahv3h9sdzgmymr6fayckjvqzs"))))
;; Extempore refuses to build on architectures other than x86_64
(supported-systems '("x86_64-linux"))))