summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorAndy Patterson <ajpatter@uwaterloo.ca>2017-04-03 09:01:26 -0400
committerRicardo Wurmus <rekado@elephly.net>2017-05-16 15:18:15 +0200
commit6de91ba2a14fd5c15721d87b63e7f8ab52a29a67 (patch)
tree49d86a1f5835ee142d890adc4afb7ac876f36625 /gnu/packages/lisp.scm
parent26a16d37ff4ae50f6e5f8eac97fa7c17631f59ae (diff)
downloadpatches-6de91ba2a14fd5c15721d87b63e7f8ab52a29a67.tar
patches-6de91ba2a14fd5c15721d87b63e7f8ab52a29a67.tar.gz
build-system/asdf: Make #:lisp a package argument.
* guix/build-system/asdf.scm (lower): Change argument name to `lisp-type'. (asdf-build): Change argument name to `lisp-type'. Remove `lisp' as an argument to the returned procedure. Change the argument passed to build phases to `lisp-type'. * guix/build/asdf-build-system.scm (copy-source, build, check) (create-asd-file, symlink-asd-files, cleanup-files, strip): Respect `lisp-type` argument. * gnu/packages/lisp.scm (sbcl-stumpwm, sbcl-stumpwm+slynk): Likewise.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index d8d858928a..aedb24587f 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -856,9 +856,9 @@ from other CLXes around the net.")
'(#:phases
(modify-phases %standard-phases
(add-after 'create-symlinks 'build-program
- (lambda* (#:key lisp outputs inputs #:allow-other-keys)
+ (lambda* (#:key lisp-type outputs inputs #:allow-other-keys)
(build-program
- lisp
+ lisp-type
(string-append (assoc-ref outputs "out") "/bin/stumpwm")
#:inputs inputs
#:entry-program '((stumpwm:stumpwm) 0))))
@@ -1145,10 +1145,10 @@ multiple inspectors with independent history.")
((#:phases phases)
`(modify-phases ,phases
(replace 'build-program
- (lambda* (#:key lisp inputs outputs #:allow-other-keys)
+ (lambda* (#:key lisp-type inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(program (string-append out "/bin/stumpwm")))
- (build-program lisp program
+ (build-program lisp-type program
#:inputs inputs
#:entry-program '((stumpwm:stumpwm) 0)
#:dependencies '("stumpwm"