summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-01-22 12:46:17 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-01-22 22:23:17 +0200
commitf3cd6633ce7348fb92735d6cd708bdc8b3b063ee (patch)
tree655a45d451cd7772782a0740f359875e81f2cdde /gnu/packages/lisp.scm
parent75033216ea9f7583d113e999f7b8ce30bbef2bca (diff)
downloadpatches-f3cd6633ce7348fb92735d6cd708bdc8b3b063ee.tar
patches-f3cd6633ce7348fb92735d6cd708bdc8b3b063ee.tar.gz
gnu: clisp: Fix building on aarch64-linux.
* gnu/packages/lisp.scm (clisp)[arguments]: Remove 'falign-functions=4' configure flag.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 10c49e0c0c..b38efac820 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
;;; Copyright © 2016, 2017 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
@@ -270,10 +270,7 @@ supporting ASDF, Sockets, Gray streams, MOP, and other useful components.")
("readline" ,readline)
("libsigsegv" ,libsigsegv)))
(arguments
- '(;; XXX The custom configure script does not cope well when passed
- ;; --build=<triplet>.
- #:configure-flags '("CFLAGS=-falign-functions=4"
- "--enable-portability"
+ '(#:configure-flags '("--enable-portability"
"--with-dynamic-ffi"
"--with-dynamic-modules"
"--with-module=bindings/glibc"