summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorAndy Patterson <ajpatter@uwaterloo.ca>2017-03-15 22:12:10 -0400
committerLudovic Courtès <ludo@gnu.org>2017-03-30 11:15:17 +0200
commitfc7d5a34d01fb9ad84bc28942595867eda12f0ba (patch)
tree32d5c3bc6ecd8622ef24008aa23c7fd5bc6fadb2 /gnu/packages/lisp.scm
parentc86c19914a2a892f57d0c601e2f1c4f86f64a7a4 (diff)
downloadpatches-fc7d5a34d01fb9ad84bc28942595867eda12f0ba.tar
patches-fc7d5a34d01fb9ad84bc28942595867eda12f0ba.tar.gz
gnu: ccl: Install included libraries.
* gnu/packages/lisp.scm (ccl)[arguments]: Add 'srfi-26' to '#:modules', and copy the included libraries to the output in the 'install' phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 60e381d30d..208da703a0 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -414,6 +414,9 @@ statistical profiler, a code coverage tool, and many other extensions.")
("subversion" ,subversion)))
(arguments
`(#:tests? #f ;no 'check' target
+ #:modules ((srfi srfi-26)
+ (guix build utils)
+ (guix build gnu-build-system))
#:phases
(alist-replace
'unpack
@@ -465,10 +468,16 @@ statistical profiler, a code coverage tool, and many other extensions.")
;; "guix package --search="
(_ "UNSUPPORTED")))
(heap (string-append kernel ".image")))
- (mkdir-p libdir)
+ (install-file kernel libdir)
+ (install-file heap libdir)
+
+ (let ((dirs '("lib" "library" "examples" "contrib"
+ "tools" "objc-bridge")))
+ (for-each copy-recursively
+ dirs
+ (map (cut string-append libdir <>) dirs)))
+
(mkdir-p bindir)
- (copy-file kernel (string-append libdir kernel))
- (copy-file heap (string-append libdir heap))
(with-output-to-file wrapper
(lambda ()
(display