summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorAndy Patterson <ajpatter@uwaterloo.ca>2017-04-03 09:01:19 -0400
committerRicardo Wurmus <rekado@elephly.net>2017-05-16 15:18:13 +0200
commit75e8b3af69dc3b1544c26ddd52bddb225f217d99 (patch)
tree6e25e5feaa0c5fae45b1dbfda38dff5a7a7d3cda /gnu/packages/lisp.scm
parent14afc7b89c8491e1bd9501eda08c410e9ab70311 (diff)
downloadpatches-75e8b3af69dc3b1544c26ddd52bddb225f217d99.tar
patches-75e8b3af69dc3b1544c26ddd52bddb225f217d99.tar.gz
gnu: cl-slynk: Explain some naming choices.
* gnu/packages/lisp.scm (sbcl-slynk-boot0): Add comments explaining its purpose and the reason its package-name must differ from its name.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index b5d5e1903b..6b4a177632 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -904,11 +904,15 @@ productive, customizable lisp based systems.")
(outputs '("out"))
(arguments '()))))
+;; The slynk that users expect to install includes all of slynk's contrib
+;; modules. Therefore, we build the base module and all contribs first; then
+;; we expose the union of these as `sbcl-slynk'. The following variable
+;; describes the base module.
(define sbcl-slynk-boot0
(let ((revision "1")
(commit "5706cd45d484a4f25795abe8e643509d31968aa2"))
(package
- (name "sbcl-slynk")
+ (name "sbcl-slynk") ; name must refer to the system name for now
(version (string-append "1.0.0-beta-" revision "." (string-take commit 7)))
(source
(origin