summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2019-03-29 15:28:38 -0500
committer宋文武 <iyzsong@member.fsf.org>2019-04-07 11:23:14 +0800
commit2005104eb2a829145b622ca9e7ad3fce34482ddd (patch)
treeecaa07f501c279586a40bcfff00bf595a5743e6e /gnu/packages/lisp.scm
parent7408b219bfb67524aa38f07af6c320c902d968a3 (diff)
downloadpatches-2005104eb2a829145b622ca9e7ad3fce34482ddd.tar
patches-2005104eb2a829145b622ca9e7ad3fce34482ddd.tar.gz
gnu: Add cl-syntax-annot.
* gnu/packages/lisp.scm (sbcl-syntax-annot, cl-syntax-annot): New variables. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 1a9455cc70..94f7a6deba 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -4282,3 +4282,33 @@ PROPER-LIST, ASSOCIATION-LIST, PROPERTY-LIST and TUPLE.")
(define-public cl-annot
(sbcl-package->cl-source-package sbcl-annot))
+
+(define-public sbcl-syntax-annot
+ (package
+ (name "sbcl-syntax-annot")
+ (version "0.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/m2ym/cl-syntax.git")
+ (commit "03f0c329bbd55b8622c37161e6278366525e2ccc")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "17ran8xp77asagl31xv8w819wafh6whwfc9p6dgx22ca537gyl4y"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ '(#:asd-file "cl-syntax-annot.asd"
+ #:asd-system-name "cl-syntax-annot"))
+ (inputs
+ `(("sbcl-syntax" ,sbcl-syntax)
+ ("sbcl-annot" ,sbcl-annot)))
+ (home-page "https://github.com/m2ym/cl-syntax")
+ (synopsis "Reader Syntax Coventions for Common Lisp and SLIME")
+ (description
+ "CL-SYNTAX provides Reader Syntax Coventions for Common Lisp and
+SLIME.")
+ (license license:llgpl)))
+
+(define-public cl-syntax-annot
+ (sbcl-package->cl-source-package sbcl-syntax-annot))