summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-29 17:34:41 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-03-29 17:34:41 +0200
commit5576cfabf3485e0cf794cc3de085a3578151ee64 (patch)
tree8ca4093d05fda6b0064d0fca429353327ec491f9 /gnu/packages/lisp.scm
parent12cb6c31df4b90d58658e88a256e36b6808e1064 (diff)
parente086d2f68b90a39bae07ae46572e5cc6b0fc4308 (diff)
downloadpatches-5576cfabf3485e0cf794cc3de085a3578151ee64.tar
patches-5576cfabf3485e0cf794cc3de085a3578151ee64.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 1ceb78c83e..258e9827a5 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -290,14 +290,6 @@ supporting ASDF, Sockets, Gray streams, MOP, and other useful components.")
(("/bin/sh") "sh"))
(substitute* '("src/clisp-link.in")
(("/bin/pwd") "pwd"))
- #t))
- (add-after 'unpack 'remove-timestamps
- (lambda _
- (substitute* "src/constobj.d"
- (("__DATE__ __TIME__") "\"1\""))
- (substitute* "src/genclisph.d"
- (("__DATE__") "\"1\"")
- (("__TIME__") "\"1\""))
#t)))
;; Makefiles seem to have race conditions.
#:parallel-build? #f))
@@ -307,10 +299,7 @@ supporting ASDF, Sockets, Gray streams, MOP, and other useful components.")
"GNU CLISP is an implementation of ANSI Common Lisp. Common Lisp is a
high-level, object-oriented functional programming language. CLISP includes
an interpreter, a compiler, a debugger, and much more.")
- ;; Website says gpl2+, COPYRIGHT file says gpl2; actual source files have
- ;; a lot of gpl3+. (Also some parts are under non-copyleft licenses, such
- ;; as CLX by Texas Instruments.) In that case gpl3+ wins out.
- (license license:gpl3+)))
+ (license license:gpl2+)))
(define-public sbcl
(package