summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorAndy Patterson <ajpatter@uwaterloo.ca>2016-10-02 22:41:35 -0400
committer宋文武 <iyzsong@gmail.com>2016-10-08 21:20:35 +0800
commit5aa608a7e81649724b363d6c292d86334eb18a9e (patch)
treed2cdbfb85a38c4ffdc2bb6324d46b2e705a35831 /gnu/packages/lisp.scm
parent3c55c780f922eb7ecfe1aba4f0c2d51ff3ea5920 (diff)
downloadpatches-5aa608a7e81649724b363d6c292d86334eb18a9e.tar
patches-5aa608a7e81649724b363d6c292d86334eb18a9e.tar.gz
gnu: Add cl-ppcre.
* gnu/packages/lisp.scm (cl-ppcre, sbcl-cl-pprcre, ecl-cl-pprcre): New variables. Signed-off-by: 宋文武 <iyzsong@gmail.com>
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 5836e75489..9b7d8a7296 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -672,3 +672,31 @@ streams which are similar to string streams.")
(define-public ecl-flexi-streams
(sbcl-package->ecl-package sbcl-flexi-streams))
+
+(define-public sbcl-cl-ppcre
+ (package
+ (name "sbcl-cl-ppcre")
+ (version "2.0.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/edicl/cl-ppcre/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1i7daxf0wnydb0pgwiym7qh2wy70n14lxd6dyv28sy0naa8p31gd"))
+ (file-name (string-append "cl-ppcre-" version ".tar.gz"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs `(("tests:cl-flexi-streams" ,sbcl-flexi-streams)))
+ (synopsis "Portable regular expression library for Common Lisp")
+ (description "CL-PPCRE is a portable regular expression library for Common
+Lisp, which is compatible with perl. It is pretty fast, thread-safe, and
+compatible with ANSI-compliant Common Lisp implementations.")
+ (home-page "http://weitz.de/cl-ppcre/")
+ (license license:bsd-2)))
+
+(define-public cl-ppcre
+ (sbcl-package->cl-source-package sbcl-cl-ppcre))
+
+(define-public ecl-cl-ppcre
+ (sbcl-package->ecl-package sbcl-cl-ppcre))