summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-05-29 15:22:04 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-06-26 13:02:28 +0200
commit63158bf6e9e2577a32b074612e9332b8a2c1ceab (patch)
tree8a695fc88fae0e234a0d3e48a4f7d50d6169bf7e /gnu/packages/lisp.scm
parent69c68b470fa9635d74b0e9522330c9604bbc42e7 (diff)
downloadpatches-63158bf6e9e2577a32b074612e9332b8a2c1ceab.tar
patches-63158bf6e9e2577a32b074612e9332b8a2c1ceab.tar.gz
gnu: Add sbcl-iolib.conf.
* gnu/packages/lisp.scm (sbcl-iolib.conf): New variable.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 29571c3930..47f39f6efb 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -5758,3 +5758,13 @@ the standard Common Lisp library. It contains a socket library, a DNS
resolver, an I/O multiplexer(which supports @code{select(2)}, @code{epoll(4)}
and @code{kqueue(2)}), a pathname library and file-system utilities.")
(license license:expat))))
+
+(define-public sbcl-iolib.conf
+ (package
+ (inherit sbcl-iolib.asdf)
+ (name "sbcl-iolib.conf")
+ (inputs
+ `(("iolib.asdf" ,sbcl-iolib.asdf)))
+ (arguments
+ '(#:asd-file "iolib.conf.asd"))
+ (synopsis "Compile-time configuration for IOLib, a Common Lisp I/O library")))