summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2019-07-08 01:44:09 -0400
committerMark H Weaver <mhw@netris.org>2019-07-14 15:02:45 -0400
commitbe7eebe26dbbea10bf40e4cf54250c79ed581952 (patch)
treef52bdeda5285818cf0d1eb164ff51f39e68879ed /gnu/packages/linux.scm
parenta4bb18921099b2ec8c1699e08a73ca0fa78d0486 (diff)
downloadpatches-be7eebe26dbbea10bf40e4cf54250c79ed581952.tar
patches-be7eebe26dbbea10bf40e4cf54250c79ed581952.tar.gz
gnu: linux-libre: Update to 5.2.
* gnu/packages/linux.scm (%linux-libre-version): Update to 5.2. (%linux-libre-hash): Update hash. * linux-libre-5.1: Rename to ... * linux-libre-5.2: ... this. Use %linux-libre-5.2-patches. * linux-libre: Switch to linux-libre-5.2. * linux-libre-arm-veyron, linux-libre-arm-generic, linux-libre-arm-omap2plus: Use %linux-libre-5.2-patches. * linux-libre-headers-5.1: Rename to ... * linux-libre-headers-5.2: ... this. * %linux-libre-5.1-patches: Rename to ... * %linux-libre-5.2-patches: ... this. * gnu/packages/aux-files/linux-libre/5.1-arm-veyron.conf, gnu/packages/aux-files/linux-libre/5.1-arm.conf, gnu/packages/aux-files/linux-libre/5.1-arm64.conf, gnu/packages/aux-files/linux-libre/5.1-i686.conf, gnu/packages/aux-files/linux-libre/5.1-x86_64.conf: Delete files. * gnu/packages/aux-files/linux-libre/5.2-arm-veyron.conf, gnu/packages/aux-files/linux-libre/5.2-arm.conf, gnu/packages/aux-files/linux-libre/5.2-arm64.conf, gnu/packages/aux-files/linux-libre/5.2-i686.conf, gnu/packages/aux-files/linux-libre/5.2-x86_64.conf: New files. * Makefile.am (AUX_FILES): Update accordingly.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e7c97c0243..2b22c344ea 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -430,21 +430,21 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
It has been modified to remove all non-free binary blobs.")
(license license:gpl2)))
-(define %linux-libre-version "5.1.17")
-(define %linux-libre-hash "049mij4z1iilrggw6plfdpcj1lnc1vqz5z445ix9677cq1fmiwlh")
+(define %linux-libre-version "5.2")
+(define %linux-libre-hash "1s9rcjwy2vmfpin5kxv015ys7lvv84y1pxl1y5aiw0y1mif0mgxb")
-(define %linux-libre-5.1-patches
+(define %linux-libre-5.2-patches
(list %boot-logo-patch
%linux-libre-arm-export-__sync_icache_dcache-patch))
-(define-public linux-libre-5.1
+(define-public linux-libre-5.2
(make-linux-libre %linux-libre-version
%linux-libre-hash
'("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux")
- #:patches %linux-libre-5.1-patches
+ #:patches %linux-libre-5.2-patches
#:configuration-file kernel-config))
-(define-public linux-libre-headers-5.1
+(define-public linux-libre-headers-5.2
(make-linux-libre-headers %linux-libre-version
%linux-libre-hash))
@@ -501,7 +501,7 @@ It has been modified to remove all non-free binary blobs.")
(make-linux-libre %linux-libre-version
%linux-libre-hash
'("armhf-linux")
- #:patches %linux-libre-5.1-patches
+ #:patches %linux-libre-5.2-patches
#:configuration-file kernel-config-veyron
#:extra-version "arm-veyron"))
@@ -510,13 +510,13 @@ It has been modified to remove all non-free binary blobs.")
"050zvdxjy6sc64q75pr1gxsmh49chwav2pwxz8xlif39bvahnrpg"))
(define-public linux-libre-headers linux-libre-headers-4.14.67)
-(define-public linux-libre linux-libre-5.1)
+(define-public linux-libre linux-libre-5.2)
(define-public linux-libre-arm-generic
(make-linux-libre %linux-libre-version
%linux-libre-hash
'("armhf-linux")
- #:patches %linux-libre-5.1-patches
+ #:patches %linux-libre-5.2-patches
#:defconfig "multi_v7_defconfig"
#:extra-version "arm-generic"))
@@ -539,7 +539,7 @@ It has been modified to remove all non-free binary blobs.")
(make-linux-libre %linux-libre-version
%linux-libre-hash
'("armhf-linux")
- #:patches %linux-libre-5.1-patches
+ #:patches %linux-libre-5.2-patches
#:defconfig "omap2plus_defconfig"
#:extra-version "arm-omap2plus"))